Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running the latest version of LUbuntu (just downloaded and install this week). This morning when my computer woke up the xscreensaver dialog popped up saying "Authentication failed". However, it never gave me a chance to enter my password.

xscreensaver dialog box

The resolution was that I had to hard power down my machine and reboot, but I would like to know why this occurred and how to prevent it in the future.

share|improve this question
My guess is that the action you took to wake up the screen attempted to enter a blank password, thus resulting in this dialog. – Tom Wijsman Aug 10 '12 at 15:01
It was a wake up from suspend. After no keyboard or mouse events, the above dialog would go away, but pressing any key or moving the mouse subsequently caused it to pop back up in exactly the same fashion. – Michael Aug 10 '12 at 16:45
Why would you (ever) hard power down your computer? Just get into a root session (for example Ctrl+Alt+F2 and login as root or use SSH) and go "pkill xscreensaver". Done. – basic6 Mar 19 '13 at 8:49
up vote 0 down vote accepted

I had the same behaviour in xubuntu 12.04.2. Then i looked into the contents of /var/log/auth.log and found this:

xscreensaver[22729]: PAM _pam_load_conf_file: unable to open /etc/pam.d/common-session

So i listed the directory and found that the file /etc/pam.d/common-session is not world-readable, like all other files in the directory. A

sudo chmod o+r /etc/pam.d/common-session

solved my problem. No idea where the wrong mode came from.

share|improve this answer

I just got this. Rather than reboot, I:

  • switched to another tty
  • logged in as root
  • ran killall xscreensaver
  • logged out of the tty
  • switched back to the graphical terminal

and the broken xscreensaver was gone :)

I suppose I could have used lynx to google for a solution while in the terminal.

@pixelbrei's solution won't work for me as I'm on systemd, but a reboot will hopefully fix things (I ran a full system upgrade pacman -Syu prior to the problem occuring).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.