Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

He.llo, I have a somewhat annoying problem. I'm using IE9 on Windows 7 Enterprise. I have configured Google to be my default search provider, and I've enabled the "Search in the address bar" option. But once every few days, the checkbox becomes unchecked, and I have to keep re-enabling it. What's even more strange is that I set the listing order to 1, and it'll also drop back to 7.

Does anyone know how to fix this?

Thanks in advance.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Windows 7 Enterprise

You're on a Domain Controller and you logon to your system using Active Directory, right? :)

You're not the domain administrator, right? :)

Short answer: it's probably Group Policy for IE.

Policy file: inetres.admx

Policy path: Windows Components\Internet Explorer\Internet Control Panel\Advanced settings\Searching

Registry path (Machine): HKLM\Software\Policies\Microsoft\Internet Explorer\Main!AutoSearch

Registry path (User): HKCU\Software\Policies\Microsoft\Internet Explorer\Main!AutoSearch

Description:

This policy setting specifies the action that will be performed when searching from the Address bar. There are two possible actions:

Do not search from the Address bar: Specifies to not use the Address bar for searches. You can still perform searches in the Search bar by clicking the Search button in the toolbar.

Display the results in the main window: Specifies that, when you search from the Address bar, the list of search results be displayed in the main window.
If you enable this policy setting, you must specify what action should be performed when searching from the Address bar. The user cannot change it.
If you disable or not configure this policy setting, the user can specify what action should be performed when searching from the Address bar.

Note that if the Machine setting is set to "Do not search from the Address bar", it will override any user group policy setting and prevent you from doing it.

It may be that your system is downloading the group policy settings from the DC and it's setting the user level setting to Do not search from the Address bar, and you keep changing it back.

Source: Microsoft

share|improve this answer
    
Yeah, I had a feeling that it was related to Group Policy, although I couldn't verify it. I did, however, check the registry editor, and there was no "Internet Explorer" listing under "Policies" for either path. Strange. –  Danny Chia Aug 11 '12 at 4:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.