Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

These describe the situation:

  • I believe the packet is being properly forwarded from the WAN to the LAN host, because WoL Magic Packet Sender utility displays a message the packet is received whenever I send from the WAN or LAN.

  • WOL works perfectly from inside the LAN. If I send the packet from
    another LAN computer, then the computer wakes up from a powered off
    state as it should.

  • WoL does not wake the computer from the powered off state when the
    packet is forwarded though the router from the WAN.

Router is a Dlink DIR-625, target host is a Windows 7 x64 computer on a Big Bang Xpower moboard.

And I reiterate: the packet shows it is being received from the WAN with the computer on, but the packet only turns on the computer when the packet originates from inside the LAN.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

You could try going into 'Network and Sharing Center'

click on your connection

Click 'properties' in the dialog box

in the dialog box that pops up, click configure

Untick "only allow a Magic packet to wake the computer"

Click ok

share|improve this answer
    
Intuitively this doesn't seem right, because the computer wakes up form the LAN. Is the packet different after NAT traversal from the WAN? –  steampowered Aug 10 '12 at 19:58
2  
This worked! Apparently the packet is changed during NAT traversal, and unchecking the "only allow a Magic packet to wake the computer" in the NIC properties allows WoL to work from the internet. –  steampowered Aug 10 '12 at 20:05
1  
For future reference: in @steampowered's case it worked because the NIC is configured to boot the computer in the event of ANY package being received in the interface. Depending of your router configuration (port forwards, etc), you may experience having your computer being started in undesired times. –  wtaniguchi Aug 22 '12 at 20:40
add comment

This is a common problem if you your router isn't multicasting the WoL package received by your WAN port.

I tried this before (I was wishing to turn on my computer remotely if I needed to RDC to it from work), and it only worked shortly after I shut down my computer. I can't find the links right now, but this has to do with your router caching the iptables, but after your computer got cleaned out of the cache it wouldn't work anymore.

So, the solution is configure your router to multicast the magic packet, right? Unfortunately, most of commodity routers won't make this possible. You would either need to "hack" your router to make routing static or buy a somewhat expensive new router.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.