Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I ran into an issue with my open office base file. It appears to be locked (I have file.odb and file.odb.lck). Now I can open the base file, but as soon as I select Tables it crashes on me and when I open any of the Reports, it crashes on me.

How do I unlock it? Or is it a different issue other than file lock?

Thanks!

EDIT (13.VIII.2012, 12.54) Let me add a bit more info. It's openoffice 3.4, running on Windows XP pro 32-bit OS. There is no screen shot I can get of you a crash, since as soon as I click on Table or trying to open any Reports, the file crashes and closes. I can open the file, just can't do anything to it.

EDIT (13.VIII.2012, 13.00) Here is what the .lck file holds in it:

HSQLLOCK 9 ¡&©

Let me know if that helps!

EDIT (13.VIII.2012, 16.45)

Here is the error message, I get after I try to save the file as...:

enter image description here

EDIT (14.VIII.2012, 10.01)

Hopefully, this one helps a little more:

enter image description here

share|improve this question
    
I believe you can simply delete the lock file. Also, it might help to know the platform/version/&c that you're running on---in order to cite the relevant docs, if nothing else. –  nerdinexile Aug 13 '12 at 16:14
    
Please add more information about "crash" : Exact description of what you do, error messages text and if possible screenshots. –  harrymc Aug 13 '12 at 17:48
    
@harrymc Can't get you a screenshot as it's closes as soon as I click on either tables or try to open a report. –  George Aug 13 '12 at 17:58
    
@nerdinexile No, that doesn't fix the issue. –  George Aug 13 '12 at 18:00
    
You mean that OpenOffice itself crashes and disappears ? There may be some useful information about it in the Event Viewer (better look immediately after a crash). You could also verify if you have all permissions on the database files (renaming the .lck file is a good start). –  harrymc Aug 13 '12 at 18:06

1 Answer 1

A wild guess is all I can do : Your database is either corrupted or something in it causes Base (not known for stability) to crash.

Assuming that your database is dead, I suggest that you try at least to recover your data.
See this tutorial : Recovering a damaged odb file.

Let me know how this recovery procedure worked for you.

share|improve this answer
    
Well, I was able to follow the instructions, so thank you for providing them! However, the script is fine, it's data appears to be corrupt. I am screwed, ain't I? –  George Aug 14 '12 at 19:56
    
Googling finds some repair products for odb files. However, they are all commercial although with trials available and some with money-back guarantee (for what's worth). I cannot recommend any of them since I never had this problem (never used OO). You could also try an alternative free suite and try to import your data. –  harrymc Aug 15 '12 at 5:47
    
... for example LibreOffice can probably open your database and might not suffer from the same bug. Google Docs may also be able to import your database. –  harrymc Aug 16 '12 at 7:49
    
I tried LibreOffice and it didn't work either. I'll try google docs next, thanks! –  George Aug 16 '12 at 15:46
    
In addition : IBM Lotus Symphony is based on OO, Zoho supports OO formats. –  harrymc Aug 16 '12 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.