Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am dual booting Windows 7 and Arch Linux (both 64bit), with GRUB2, using the 64-bit EFI version.

I partitioned my drive into a GPT drive and installed Windows first according to this guide. I then installed Arch Linux using the Beginner's Guide, installing grub2-efi-x86_64 in the process.

Everything is working fine now, but with one problem. I can set the boot priority in BIOS (or is it UEFI?) to have GRUB boot try and boot before Windows Boot Manager. Then I chainload Windows Boot Manager using GRUB. However, when I actually use Windows in this manner, upon shutting down and turning on again, or rebooting, Windows seems to set Windows Boot Manager first in the priority list again, with the result being I have to manually set GRUB again, or I can't boot into Linux.

My motherboard is an Asrock H61M/USB3, if that helps.

I want to know how to turn off this behaviour.

share|improve this question
    
I have a dual boot of Windows and Linux Mint. When installing mint after windows I put mint boot in its own partition so that Windows boot manager is first. Installed easybcd (freeware) and added linux mint as well as Windows so that option to boot into windows or mint is available and default OS can be set in easy bcd. –  sarathy Aug 11 '12 at 12:56

2 Answers 2

That does seem to be a BIOS issue but I do no know Asrock boards or their tendencies.

@Terdon: MBR is not relevant to GPT disks as such; also, Windows can and will indeed 'touch' the MBR in three cases:

  1. Running bootrec /fixmbr and possibly bootsect /nt60 <os_drive>

  2. Re-installing Windows

  3. Running Windows repair, startup errors.

GPT disks have an 'encapsulated' protective mbr section and grub-install would not work on a GPT disk, as one would need grub-x86_64-efi.

share|improve this answer

Where have you installed GRUB? If you install it to the MBR of your 1st hard drive it should work ok. Log into linux and try this (as root):

grub-install /dev/sda

Tha will install GRUB to the MBR of disc sda. In my case, at least, windows never touches that again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.