Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just purchased HP Pavilion dv6 6C00TU 3 weeks ago and its webcam was working 100% perfectly. 3 days ago, I just downloaded a software named as magic-ivisual something. It is a software that shows some cartoon characters and those characters move same as the person using the laptop is moving.

Anyways, the problem is, after installing the magic-ivisual software, my webcam stopped working. There is CyberLink YouCam installed in this laptop and when I open it up, it shows me this message:

Warning: no webcam detected. try plugging in a webcam into your computer now. if you are using an integrated camera, make sure that is turned on.enter image description here

Solutions I have tried:

1 Un-installed the webcam and re-installed it

2 Checking the drivers but could not find the Imaging section in my device manager

3 Restarting my laptop many times, but nothing happened

4 Tried camera using Skype, and www.neave.com

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

If your operating system is a recent version of Windows and you have a system restore point just before the date you installed the magic-ivisual program, you could restore to that point.


Start -> Control Panel -> Backup and Restore -> Create a restore point or change settings -> System Restore

Carefully choose a suitable restore point.


Windows 7 home edition examples for setting up and using system restore points. Other versions of Windows are slightly different.

configuring system protection list of restore-points

share|improve this answer
    
I am using windows 7 Basic Home Edition. How can I restore it from that point? I have updated my question as well. –  Asma Wakeel Aug 11 '12 at 15:30
    
See updated answer –  RedGrittyBrick Aug 11 '12 at 15:42
    
I just created a restore point and nothing happened. I did not find any change in my system. –  Asma Wakeel Aug 11 '12 at 17:56
    
The link is named "create a restore point" but what you actually do is not create a new one but restore an existing point dated prior to the date the problem arose. –  RedGrittyBrick Aug 11 '12 at 20:11
    
There is no other restore point other than the one I created last time. What can I do now ? –  Asma Wakeel Aug 13 '12 at 14:54
show 1 more comment

Goto

RUN > type "devmgmt.msc"

Then in Device Manager, go to VIEW > SHOW HIDDEN DEVICES then, UNINSTALL the devices with YELLOW EXCLAMATION POINT

REBOOT (without device attached)

INSTALL DEVICE DRIVER First (from CD or MSI/EXE file) shutdown one more time. Plug back the device (webcam). Restart computer.

This should help solve your problem for corrupted device driver.

Recommendation: Next time when you want to remove webcam, simply shutdown the PC and then remove the webcam (or, Printer, iPOD, Nook, any device). This little practice should prevent future 'AlkaSeltzer time' and your system will be happy as you will be.

share|improve this answer
    
There is no device with yellow exclamation mark. –  Asma Wakeel Aug 11 '12 at 15:56
    
Alternate way to remove (by means of disabling) a driver is to install AUTORUNS and observe driver in the Windows\System32 folder the file with SYS extension. Usually, graphic drivers are loaded when video card and other graphic device drivers are loaded. By disabling the specific driver for your magic-ivisual you can return to a pre-installation state. Please read on how AUTORUNS work, it can become your best buddy in solving so many of thePC problem, now and in the future. filehippo.com/download_autoruns –  C2940680 Aug 15 '12 at 2:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.