Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7. I tried to copy five (movie) files to my Sandisk pen drive. It took 10 minutes to finish, when i was copying them individually.

When I selected the same five files as a group and then copied them to another folder of my pen drive, it took me only 5 mins.

Note that the file 's size is same each of 500 MB.

Why is this difference?

share|improve this question
    
can you repeat that experiment when starting from a fresh booted windows? as in .. boot fresh, select indivdually, measure time, reboot, select as group, measure time? –  akira Aug 12 '12 at 13:14
    
@akira i installed windows7 last month and havent installed any software except ms office,and i m having ddr3 ram with amd x2 proceessor does hardware make diffrence? –  BlueBerry - vignesh4303 Aug 13 '12 at 2:38
    
i didnt ask about hw, i asked about repeating the experiment without reusing the OS-filecache (which triggers as soon as you work on files). –  akira Aug 13 '12 at 6:03
    
@akira i tried with fresh installation at my friend's system with same hardware configuration it took me 7mins for individuals and for group it took me about 4mins,i also noted that if i add individual files the time shown for first windows is 2mins &transfer rate is 2mb/sec,and for 2nd file estimated time 5mins &1mb/sec –  BlueBerry - vignesh4303 Aug 13 '12 at 6:07
    
i didnt say "fresh installation" either. just reboot the system to flush away the systems IO-cache ( msdn.microsoft.com/en-us/library/windows/desktop/… ). you might measure the speed of really reading the files vs getting the files from the cache (aka "ram"). also: try to measure it the other way around: first group the files, then transfer individually. also: do you batch the the individual files so the copy process runs in sequence or is the copying done in parallel (as in: you just drop the files onto the pen and 5 copy-actions are in progress at the same time)? –  akira Aug 13 '12 at 6:11

1 Answer 1

up vote 1 down vote accepted

This is due to memory resources allocation. For 5 movies (2GB total), a 2 GB file swap is created; but for 1 movie (400MB) * 5 it has to created and then delete file swaps. Add additional CPU priorities.

A better way to copy would be to use TeraCopy or Roadkil's Unstoppable Copier, which bypasses the operating system and use DMA Channel (direct memory access method). Note: This applies to USB1.1/2.0 only. USB3.0 is way too fast, but no USB pen drives available (atleast for now - Aug 2012)

share|improve this answer
    
any references to backup your claim that a "swap" file is created? i am also interested in a reference for that "terracopy uses dma" which makes it faster on windows7 than the built-in file-copy-mechanism (which i tend to believe is bogus)? –  akira Aug 12 '12 at 13:07
    
@C2940680: Huh? It's August 2012 and you're saying there are no USB 3.0 pen drives available? Also, I'd love to see some hard figures about the TeraCopy/Roadkil Copier vs. Windows copy speeds as well. –  Karan Aug 12 '12 at 16:29
    
i am using usb 2.0 ,if we clean the temp memory will it be fast before copying..?i like to mention i noted in my bios usb port transfer speed to hispeed –  BlueBerry - vignesh4303 Aug 13 '12 at 2:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.