Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ultimately, I'm trying to install the windows phone app SDK so that I can put an app I've made on my phone.

To do this, I am told I need to install SP1.

When I attempt this I get the following:

"The feature you are trying to use is on a network resource that is unavailable visual studio riaservices.msi"

I download the riaservices.msi and point the dialog to it, and I get the message:

"The file is not a valid installation package for the product WCF RIA Services V1.0 for VS 2010."

I've downloaded the ISO as mentioned in a related post on this website, but I've no idea what I'm doing with that now it's mounted.

Some of the features I've tried to install have asked me to insert the CD which I don't have, I downloaded it for free from a university scheme.

Can anyone help me fix this? It's infuriating beyond belief.

share|improve this question
    
I've had a similar issue, but it was because (believe it or not) M$ website that was downloading some install files in the background was down. Once the site went back online, it worked. I know it's old, but maybe this is the issue and it's trying to download resources? kbalertz.com/939401/… –  skub Aug 12 '12 at 21:49
    
Appreciate the response! It's been over 24 hours now and it's still not working - I'd assume if that was the issue that it'd be resolved by MS by now? I guess this is why the other solution said download the ISO, which I have even if I don't know what to do with it. –  Joshua Mee Aug 13 '12 at 15:58
add comment

1 Answer

up vote 2 down vote accepted

An old problem, but for future readers...

Try using the M$ FixIt found at the URL below to uninstall the offending program, "RIA Services" in this case. That will clean up the installation which appears to be the problem.

http://support.microsoft.com/mats/Program_Install_and_Uninstall

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.