Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a script for installing a program.

https://github.com/mkonecny/airtime_centos/blob/master/centos.sh

When I try to run it I get:

64-bit installer only
LANG=en_US.UTF-8
install/uninstall parameter required

I tried chmod it. I tried sudo ./centos.sh

Am I missing something?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

You are in fact successfully running the script. What you're seeing is the script's output.

64 bit installer only

from

mach=`uname -m`
if [[ "$mach" != "x86_64" ]]; then
    echo "64-bit installer only"
fi

This is telling you that the installer script is only meant to be run on x86_64 (64-bit PC) hardware, and your computer is using a different processor architecture (your operating system is probably 32 bit)

At this point, the script should logically quit, but the scripter forgot to put that in, and the script just runs on.

LANG=en_US.UTF-8

This is the output of

locale | grep "LANG" | grep -i "UTF.*8"

The script uses this to check that your system uses unicode. In my opinion, the scripter is being sloppy here again and should have suppressed the output of that line.

Finally,

install/uninstall parameter required

is from the last part of the script:

if [[ "$1" == "install" ]]; then
    install
elif [[ "$1" == "uninstall" ]]; then
    uninstall
else
    echo "install/uninstall parameter required"
fi

The script is trying to tell you that you're supposed to run it like so:

./airtime_centos.sh install

or, to uninstall,

./airtime_centos.sh uninstall

However, that probably won't actually work as expected since the script will try to install 64-bit packages on your 32-bit system.

share|improve this answer
    
/centos.sh install -bash: ./centos.sh: Permission denied –  Trance84 Aug 12 '12 at 21:36
    
the thing is it is a unix software that is supported on 32 bit...but no guide was written for centos so a user created this file..this is the original page -> en.flossmanuals.net/airtime-en-2-0/manual-installation –  Trance84 Aug 12 '12 at 21:37
    
-bash: ./centos.sh: Permission denied is your shell, bash, telling you that it does not have the rights to execute the file. You have to set the execute bit using chmod +x. –  tjollans Aug 12 '12 at 21:40
    
its working after chmod +x and install after ./centos.sh :) and it seems its defaulting to i686 packages..so well see...thank you all for your kind help! –  Trance84 Aug 12 '12 at 21:44
add comment

Try enter in to root
then type

 bash   file_path/yourfile.sh  

...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.