Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I try to cd ˜/ it responds:

-bash: "cd: ˜/: No such file or directory"

I also don't seem to have a .bash_profile or .profile.

share|improve this question
    
Your PATH is broken, which makes sense if you have no .bash_profile or .profile. Check the answer at unix.stackexchange.com/questions/7076/… –  user3463 Aug 12 '12 at 23:06
    
I sort of thought so, but all the commands work... just not ˜/ (that i've found) FYI when i type set my path looks like > PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/X11/bi‌​n –  Bert Smith Aug 12 '12 at 23:59

1 Answer 1

up vote 12 down vote accepted

That's the wrong tilde character. You typed a "small tilde" (unicode U+02DC), when you want a plain ASCII tilde character (unicode U+007E). Compare the following commands:

cd ~    # plain tilde: this works
cd ˜    # small tilde: doesn't work, because there's no file named "˜"
share|improve this answer
    
Soooo then where on my keyboard do i find the "Big" tilde, I mean the tilde character next the 1 key has worked for me in the past. This just seems to be a recent event. I guess it's possible that the key got re-mapped somehow??? –  Bert Smith Aug 13 '12 at 1:55
    
Not doubting you answer (as i copied your cd command to my terninal and viola)... but I guess the real question is how do i fix it –  Bert Smith Aug 13 '12 at 1:58
    
@Bert Smith: Sounds like the correct key on the keyboard. Check your language and regional settings control panel (I'm not sure about the correct terminology for OS X). –  martineau Aug 13 '12 at 2:12
    
Does that key type the standard tilde or small tilde in other apps (e.g. if you type a tilde in TextEdit, then copy & paste it into Terminal, which one do you get)? If it's typing the small tilde everywhere, look in System Preferences -> Language & Text pane -> Text and Input Sources tabs (and possibly the Keyboard pane). If it's just Terminal, check its preferences, especially the Settings section -> Keyboard tab. Oh, and just to be sure: what kind of keyboard is it? Anything at all unusual (non-Apple, non-US, etc). –  Gordon Davisson Aug 13 '12 at 4:35
    
Yes... small tilde everywhere and I'm using the built in keyboard on my 17"inch MBP running Lion –  Bert Smith Aug 13 '12 at 17:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.