Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer seems to randomly turn itself on, usually in the middle of the night when I'm asleep. It's in my bedroom so it wakes me up. I'm running Windows 7 and I don't know if it's trying to runs updates but it doesn't seem to be doing anything once it's on. It only seems to do it only when it's in sleep mode rather than completely shut down.

share|improve this question
3  
Is your house haunted by tech-literate ghosts perchance? –  random Sep 24 '09 at 8:39

5 Answers 5

up vote 11 down vote accepted

You need to check what wakeup mechanisms you have configured.
Any on of them will push it out of sleep.

Check Fix for Windows 7 "random wake from sleep" problem.
It refers the powercfg tool,

powercfg -lastwake

will tell you what tripped it the last time...
But, do look at the rest of that posting too.

share|improve this answer

Cant add comments or vote yet, but nik is right. It often happens with wireless mouse/keyboard. They probably sends some signals from time to time to receiver or something like that. But what ever the

powercfg -lastwake

will tell you, you can disallow this device from waking your pc up in

device manager -> your device -> Power Management tab -> uncheck the Allow this device to wake the computer.

Edit: After reading the article from nik's post I recommend you do same :)

share|improve this answer

I had this problem, it's to do with the network card. I did this:

  1. Right click on your “My Computer” then select Properties.
  2. Click Device Manager on the left side of the Properties window.
  3. Check your Network card on the Network Adapters (Click on the + sign to expand).
  4. Right click on your network card and select properties.
  5. Go to the Power Management tab and untick the option there to prevent your network card from ever waking up your Windows.

    alt text

If it still doesn't work:

Check out your Power Management Options on your Control Panel (Start, Control Panel, Power Settings, Change plan settings, Change advanced power settings).
-> “Multimedia settings” option, “When sharing media.” ->”Allow the computer to sleep.
-> Check other options one by one while you’re at it.

share|improve this answer

Is it the same time every night? Take a look at the task scheduler. Somewhere in there (you'll have to rummage) will probably be an entry that conforms to the time that it wakes up. Then see if you can disable it or change the time.

share|improve this answer

The info above is very good.

A couple of other things to bear in mind.

The machine can be woken by modem as well. I doubt its plugged in bust just in case.

Also, if you have a scheduled task / process set, that can be configured to wake up the machine as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.