Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use virtualbox to install xp.

When I boot, it shows:

enter image description here

And I can boot into safe mode.

How to solve it?

Thank you~

share|improve this question
    
read this and say whether it can be appiled to you i googled and found this for intellppm.sys answers.microsoft.com/en-us/windows/forum/windows_7-system/… and please crop the image and post it –  BlueBerry - vignesh4303 Aug 13 '12 at 8:29
    
Adding a +1 for this even though my BSOD referenced P3.sys. I followed the "if that doesn't work" steps on the accepted answer below, substituting P3.sys for intelppm.sys and I'm all set. –  panhandel Nov 13 '13 at 17:29
add comment

1 Answer 1

up vote 5 down vote accepted

The DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS bug check has a value of 0x000000CE. This indicates that a driver failed to cancel pending operations before unloading.

More details and fixes here: http://msdn.microsoft.com/en-us/library/windows/hardware/ff560226%28v=vs.85%29.aspx

If you are seeing this problem repeatedly you can manually disable these drivers (with no negative side effect) by going to the following location in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Processor and changing the Start value to '4'. Or
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Intelppm and changing the Start value to '4'.

If that doesn't work then try to:

  1. Boot in Safe Mode + Networking (F8 at startup)
  2. Go to %Systemroot%\Inf\ and delete all OEM#.inf
  3. Search for intelppm.sys in the c:\windows\ (search for hidden directories and system files) - Delete the 3 results of intelppm.sys
  4. Reboot the Guest normally

The suggestion above (and more) is from VirtualBox forum

HOWEVER, your issue may not be due to the Virtual Box as it mentions the intelppm.sys

So, if the above doesn't work, try

  1. Boot in Safe Mode + Networking (F8 at startup)
  2. Delete the files intelppm.* existing in the c:\windows\ and sub-dirs.
  3. Go to %Systemroot%\Inf\ and delete all OEM*.inf
  4. Re-install Guest Additions.
  5. Reboot
share|improve this answer
    
I change regedit by your method,and it works! Thank you~ –  sam Aug 13 '12 at 8:36
    
I'm glad it all worked for you :) –  Dave Rook Aug 13 '12 at 8:37
    
I have to wait for 2 minute...by the rule of this board. –  sam Aug 13 '12 at 8:38
    
What happened when I disable intelppm.sys? What function I will loss? Thank you~ –  sam Aug 13 '12 at 8:40
    
I'm not 100% certain but you can always re-install the drivers. For example, you can download the drivers from the Intel website depending the Network Adapter you choose; if you need 100Mbps choose PCnet-FAST III, as it should not give such problem as you're experienced. However, if it works for you now, I would leave it as is. –  Dave Rook Aug 13 '12 at 8:42
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.