Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

Chrome offers to restore the last session when it did not shutdown properly (power outage, Chrome crashed, ...).

How do I disable that? (Setting or command line switch)

I'm using a batch file that starts (among other things) chrome in kiosk mode for a single page on windows startup. Even after power outage etc. it should only launch that page without the ruckus.

share|improve this question

marked as duplicate by DavidPostill, Steven, BlueBerry - Vignesh4303, Excellll, Dave Jul 29 at 13:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

It might not be possible to disable it. If you are using a batch file, I would simple delete the file that handles the session, before you launch Chrome. – Ramhound Aug 13 '12 at 12:40
@Ramhound Which file(s) would that be? "User Data\Default\Current Session" and "User Data\Default\Current Session" don't seem to make a difference. Neither does "User Data\chrome_shutdown_ms.txt". – riha Aug 13 '12 at 13:04
@riha simply clearing history and sessions before closing the browser will solve your problem and there were some third party tools which would automatically wipe history when your system is restarted – BlueBerry - Vignesh4303 Aug 13 '12 at 13:04
A power outage prevents clearing history / sessions. Deleting the whole profile folder works, but that feels like a bit too much... – riha Aug 13 '12 at 13:30
@janot and other closevoters: this question is more highly upvoted and has a lot more views than the linked duplicate. I've voted to close the older, less-viewed one as a duplicate. – ncdownpat Jul 23 at 0:28

6 Answers 6

up vote 15 down vote accepted

I know this is old but I thought it would be helpful to others that may come across this.

I had this issue and tried the flags settings but that did not help. adding --incognito to the command did resolve the issue.

chrome.exe --kiosk --incognito

I tried this in various fashions of crashing Chrome and pulling the power to the PC. In all tests the system would power up and go into kiosk mode without the frown face error message.

share|improve this answer
Is this any different than @Dom's answer? – Andrew Lott Jul 12 '13 at 13:39
note, incognito mode disables caching, so if that's important for your application this is not a great option. – ericsco Oct 24 '13 at 19:43
How to keep caching but disable that feature only? – YumYumYum May 27 at 8:48

Someone has suggested just running Chrome in Incognito mode to get around the problem here. If you are running in full screen mode and redirecting to a specific page that shouldn't be noticeable. I know that's a bit of a work around.

share|improve this answer
That certainly provides some helpful info, thanks. My current workaround is to delete the whole profile folder before starting chrome. Incognito is probably the better choice. I'll report back. – riha Aug 15 '12 at 5:39
note, incognito mode disables caching, so if that's important for your application this is not a great option. – ericsco Oct 24 '13 at 19:44

Try this

  • go to chrome://flags/
  • then click Enable on the link that writes: "Disable Better session restore"

I hope this helps

share|improve this answer
Looks like they removed this flag... (Windows Chrome v38), bummer. – Ben Roberts Oct 28 '14 at 18:22
@YumYumYum - If you believe this is still possible, and if you can provide an English screenshot, then that qualifies as an answer provided its not an identical solution and it shouldn't be if the flag was renamed and now is something else. – Ramhound May 28 at 0:22

try this line

chrome.exe --kiosk --disable-session-crashed-bubble ""

For more detailed information

share|improve this answer
this works well if you include --disable-infobars which then kills the warning alltogether – l0ft13 May 28 at 8:35

I see some inconveniences in the solutions provided:

--incognito switch removes cache, what is pretty bad in most circumstances.

(Copy-pasting chrome help )

Google Chrome has hundreds of undocumented command-line flags that are added and removed at the whim of the developers.

--disable-session-crashed-bubble depends of which version of chrome are you using, the most actual version v39 doesn't have this setting allowed.

The solution I did was to alter the user profile and overwrite the crash status to a normal close status, It's a simple hack that works perfect.

This is the script I run in kiosk-mode in a chrome-only session under Ubuntu 12.04 and 14.04

sed -i 's/"exited_cleanly": false/"exited_cleanly": true/' ~/.config/google-chrome/Default/Preferences
sed -i 's/"exit_type": "Crashed"/"exit_type": "None"/' ~/.config/google-chrome/Default/Preferences
google-chrome --kiosk "http://some_url"

It simply finds and replace the string

  • "exited_cleanly":false
  • exit_type": "Crashed"


  • "exited_cleanly": true
  • "exit_type": "None"

So, no matter how chrome has closed. It will always think it has closed gracefully. (Tested in many chrome versions)

share|improve this answer
If I had used linux back then, I would've probably given this a try. – riha Feb 17 at 9:59

Open chrome \ Default \ Preference, and change the value to

"exit_type": "none",

"exited_cleanly": true,

Save the file, and put him to attribute "read only". Tested on various versions of the Chrome browser

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.