Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Linux Mint 13 Xfce in a VMware Workstation 8 VM and set the resolution from 800x600 to 1280x768 and now I get permanently logged out when I try to login.
I knew how to get back to my old resolution back in the xorg.conf days but Linux Mint now uses xrandr which won't display any displays when running it because X is not running (of course not - I can't login over GUI).

I know that there are configuration files in /etc/X11/Xsession.d/ because I configured a debian based thinclient's resolution in a file called /etc/X11/Xsession.d/91configure_display but that file doesn't exist in my Linux Mint VM.

So, how do I reset my X screen resolution from console?

Edit: I forgot to tell you that I can't change resolution in console:

# xrandr -s 800x600
Can't open display

This message appears every time I use xrandr or xrandr -s *resolution*.

Update: I tried what bWowk suggested:

# export DISPLAY=:0.0
# xrandr -s 800x600
No protocol specified
No protocol specified
Can't open display :0.0

So, that doesn't work either. Isn't there a configuration file that is executed every time X starts?
X is running btw - ps aux | grep X shows one process /usr/bin/X running.

share|improve this question
    
I think that, although not created by default anymore, the X server still respects the /etx/X11/xorg.conf file. Have you tried creating one and setting a resolution there? – terdon Aug 14 '12 at 0:56

X isn't running or just Xfce?

If there is a live X session, try this:

export DISPLAY=:0.0

And then:

xrandr -s 0

This will reset it to default resolution. Also, you can chose your own resolution:

xrandr -s 800x600
share|improve this answer
    
I'm sorry, I forgot to write that xrandr -s 0 and xrandr -s 800x600 doesn't work in the console like xrandr to display current configuration. It says Can't open display. I'll edit that in my question. – wullxz Aug 13 '12 at 14:40
    
Which graphic driver are you using? – bWowk Aug 13 '12 at 14:43
    
VMware tools. I'll edit what your new suggestion changes... – wullxz Aug 13 '12 at 14:44
    
Try running this: export XAUTHORITY=/home/<user>/.Xauthority and than back to the export DISPLAY=:0.0 and xrandr -s 0 – bWowk Aug 13 '12 at 14:54
    
Doesn't work either. Same error as last try. And /home/<user>/.Xauthority doesn't exist. – wullxz Aug 14 '12 at 17:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .