Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with ndiswrapper. I am using ndiswrapper with the Netgear WN121t USB Wifi adapter and by now I think I tried almost every .inf file on the net.

I got the device working so far (it gets detected by ubuntu and it finds my network) Problem is that ndiswrapper shows

Aug 13 04:42:04 local kernel: [ 2043.438367] ndiswrapper (NdisMSetInformationComplete:2542): invalid task

and the connection times out.

I am using Ubuntu 12.04 Precise Pangolin 32-Bit on a Toshiba Satellite (the driver is 32-Bit also!) The device I'm trying to get to work is a Netgear WN121t.

I can't post the driver file because I tried about 20 different drivers and the error message is always the same.

Here is the log file: Syslog file

I would really appreciate your help!

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

This is the nature of ndiswrapper. It is pretty much broken by design, and only works with a few specifically-supported drivers. It's like running wine in the kernel, which is far, far worse than running it in userspace, because one wrong move and you kernel panic.

Ndiswrapper is not really intended for production use, and by all reports, even people who get it "working" will encounter stability, bandwidth or data corruption problems. Over the years I've tried it with over a dozen wifi chipsets, and every single one of them either crashed the kernel or had some kind of show-stopping behavior at runtime.

It's a bad solution to a tough problem. If no native driver at all exists for your wifi adapter, all you can do is:

  • Try to file a bug with Ubuntu and see if anyone can get it working (extremely unlikely, as most bugs dealing with restricted drivers are ignored)
  • Try to file a bug with ndiswrapper upstream and see if anyone is still maintaining it and looking at bug reports (extremely unlikely)
  • Try upgrading to the latest kernel and compiling the newest ndiswrapper from source, as whatever Ubuntu is shipping is probably out of date
  • Try googling for a Linux driver for your wireless chipset; due to licensing concerns, Ubuntu does not ship certain chipsets' native Linux drivers, even though they are open source... for example they refused to implement Ralink's rt2800 driver back before the mainline kernel developers built their own.
  • Try another wireless chipset that is known to be natively supported on Ubuntu (best bet is Intel chipset or Qualcomm Atheros; Ralink is ok these days too)
share|improve this answer
    
I was afraid you'd say something like that :( well off to buy a new usb-wifi thing –  jo_fryli Aug 13 '12 at 20:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.