Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is not a firewall issue.

I have an ADSL connection, and have set port 50420 to be forwarded locally for use with utorrent. Everything was working fine, and various tests and utorrent itself shows the port as being forwarded correctly, as well as various other client programs.

However, after sharing my internet(LAN) connection via my wireless connection, the port stops being forwarded. Nothing gets changed on the modem, so I am unsure as to why this is happening.

My Ethernet adapter has DHCP enabled, and gets an addresses automatically from the modem. Sharing this connection assigns my wireless connection a static IP of 192.168.0.1 and allows for clients to use my computer as a gateway.

I am unsure why this prevents the port from being forwarded correctly....

share|improve this question
    
Where do you set the port forwarding rules? On the ADSL modem? A router? Can you verify the IP addresses you used for port forwarding and are they still valid after enabling ICS? Maybe ICS assigned your host a different IP. –  hyperslug Sep 26 '09 at 2:54
    
Portforawding is set on the ADSL modem. The IP address is still valid. My LAN connection IP does not changed, and is assigned via DHCP from the modem. Only my Wireless IP changes. –  Bill Grey Sep 26 '09 at 3:44
    
Odd, the configuration sounds right. I'd test it myself, but I don't have a Vista machine. –  hyperslug Sep 26 '09 at 5:51

5 Answers 5

up vote 2 down vote accepted

This was solved by manually setting my outgoing IP to my internet connection in my torrent client. The problem was nothing to do with firewall settings.

share|improve this answer
    
If your desktops's ethernet adapter IP was the same with or without ICS, why would an explicit setting in uTorrent fix it? –  hyperslug Sep 27 '09 at 15:44
    
sounds like uTorrent gets confused about which IP address to send traffic on. not sure why it can't figure out the route to the internet on its own, but maybe it's useful if you were keeping your torrenting inside the LAN. –  quack quixote Oct 3 '09 at 9:43

ICS enables the Windows Firewall, make sure to make an exception for uTorrent.

share|improve this answer
    
utorrent is still working quite well, and can download quite fast, but only a few torrents at a time, much decreased from before. Definitely not a firewall problem. –  Bill Grey Sep 24 '09 at 10:07
    
it works alright, but i had exactly the same problem. without opening the uTorrent port in Windows Firewall, NO DICE with portforwarding. –  Molly7244 Sep 24 '09 at 10:13
    
Bill, don't assume, check it. –  Bender Sep 24 '09 at 11:23
    
I'm not assuming anything. It is not a firewall problem. Molly, did you ever get around it? –  Bill Grey Sep 24 '09 at 17:30

Have a look at this guide

http://forum.portforward.com/YaBB.cgi?num=1134525903

share|improve this answer
    
That seems to be more for clients needing to use utorrent, which is not the case here. –  Bill Grey Sep 24 '09 at 10:08
    
Are you trying to do the utorrent on the pc that's doing the sharing? –  Col Sep 24 '09 at 10:12
    
Yes, as it is also my personal computer. –  Bill Grey Sep 24 '09 at 17:29
    
I think from the way ICS works it sets your PC up as a router, what I'm not sure about is whether it sends it's own traffic through this router or if it just does that directly. If it's passing it's own traffic through this virtual router you might still have to follow those instructions. –  Col Sep 25 '09 at 7:45
    
It is passing traffic directly –  Bill Grey Sep 26 '09 at 7:14

I don't fully get your environment, but I am guessing you have a router to your pc, then your pc is sharing.

It is fine to do that, but your pc - with ICS on, acts like a router as well.

You have to go into ICS options and set up port forwarding (I believe on the advanced tab of the network card you are sharing)

You may have problems with "Double NAT" but the only way to find out is to try it.

share|improve this answer

Did you check if your local IP changed since you set it up on the router? In a DOS console, type 'ipconfig', look at your local IP address on your PC, then check that the router is indeed forwarding port 50420 to that IP.

share|improve this answer
    
If my local ip changed, I would not have internet access. It has not changed, and nothing has changed on the modem. Portforwarding is indeed set up correctly. –  Bill Grey Sep 26 '09 at 7:14
    
Not necessarily. If your ADSL modem reassigned a new IP via DHCP, internet would still work but the port forwarding rule would be wrong. I'd set up a static assignment on the modem if possible. Anyway, I trust you when you say the rule is right. –  hyperslug Sep 26 '09 at 7:19
    
Yes, I meant that no new IP has been assigned. It really is puzzling. I even turned on the firewall to log everything, and no denied requests for torrent stuff. Just a heap of IPv6 ICMP stuff was denied. –  Bill Grey Sep 26 '09 at 8:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.