Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an network configuration like:

  • Ethernet cable from ISP connected to Windows XP machine, configured with static IP 192.168.0.3
  • Another ethernet connection from 2nd Windows XP machine's network adapter to a Wi-Fi router (D-Link Airport G+)
  • XP set to "Share internet connection", the 2nd adapter configured as static to 192.169.0.1
  • D-Link Airport Wi-Fi router also configured as "static connection", it's IP set to 192.169.0.2, default gateway set to 192.169.0.1. Network mask everywhere is 24.
  • Laptop computer connected with the router with static IP 192.169.0.3

The problems are:

  • XP machine sees the router (it's able to ping it and access it via the web admin tool)
  • The router somehow cannot PING the XP machine (using the tool provided by the web-based admin tool)
  • The laptop computer cannot ping anything and cannot be pinged
  • The router is only accessible when the ethernet cable is connected with a router's 1-4 LAN port, when I connect it via "WAN" port (which I believe is the proper one) it's not visible from the XP machine

If you have similar experience with configuring a network like this I would really appreciate your help. I cannot use the Wi-Fi router with the ISP cable itself.

share|improve this question
    
I think you're taking the wrong approach, you should be able to use the router directly with the ISP's router. It will make your life much easier if you fix that problem rather than this. If you could give details of why that didn't work for you it would be better. –  Col Sep 24 '09 at 9:53
    
My ISP's policy doesn't allow that. I know it's weird but I cannot find any way around it. –  Darius Sep 24 '09 at 9:58
    
192.169.?.? is not a reserved IP for internal networks. Use 192.168.1.? instead. –  hyperslug Sep 24 '09 at 10:01
    
Have you tried getting the router to clone the MAC of the XP machine that can connect? –  hyperslug Sep 24 '09 at 10:04
    
The ISP wouldn't even know if you configure the wireless router with exactly the same IP address as you have on the ethernet port of your laptop it should just work. –  Col Sep 24 '09 at 10:04
show 8 more comments

6 Answers

Your router is probably not configured properly. There is no way for an ISP to differentiate a router from a software firewall if configured properly. Make sure that:

  • Your ISP's modem has routing and DHCP disabled (the modem, not the router: they come built in with that lately... Just put it in bridge mode)

  • Remote Management is disabled on the router. (This will not prevent you from configuring it while inside the network, Tools > Admin > "Enable Remote Management" unchecked)

  • You use MAC address cloning to clone the MAC address of your currently connected machine

  • DHCP is enabled on your router and is giving out valid addresses (192.168.x.x)

  • Your ISP's modem is connected in the WAN port of your router.

If all of the above are true, you shouldn't have any problems using your router to access the Internet from all your computers.

share|improve this answer
    
If I clone the MAC address of current machine connected with the ISP, should I also change the MAC address of the computer itself? In order not to make them collide with each other. Or that won't be a problem? –  Darius Sep 24 '09 at 13:36
    
You don't need to, the router handles that just fine. –  hyperslug Sep 24 '09 at 16:57
    
@Darius: No... The router will report the cloned MAC only on the WAN interface. The real router MAC will be reported to the LAN interface. –  Andrew Moore Sep 24 '09 at 17:01
add comment

Disable routing and DHCP on the router and just use it as a switch:

alt text

share|improve this answer
    
I already disabled DHCP on the router. The problem is that the Windows XP (host) machine, the router and the client laptop machine are not seeing each other as a LAN. –  Darius Sep 24 '09 at 10:18
    
Just use ICS on the host machine. Start -> Run -> ncpa.cpl -> right-click internet NIC -> Advanced -> Allow other users to connect.... No need for static assignments, since the host acts as DHCP. –  hyperslug Sep 24 '09 at 10:25
    
Ok, I get it. I will try that in few hours. Thanks! –  Darius Sep 24 '09 at 10:27
add comment

That's a very weird set up why haven't you just connected the wifi router to the ISP modem with the ethernet cable

share|improve this answer
    
My ISP's policy doesn't allow that. –  Darius Sep 24 '09 at 9:52
    
It doesn't allow for more than one computer to be connected to your internet connection? Unbelievable... –  hyperslug Sep 24 '09 at 9:56
    
2nd computer costs 20 Euro / month, so I try to avoid that. –  Darius Sep 24 '09 at 10:04
1  
I'd be tempted to change ISPs to someone more understanding. –  Col Sep 24 '09 at 10:13
add comment

Check in Windows Firewall that you do not have PING disabled. On the settings, look for ICMP Echo.

Anyway, it sounds to me like the network is unnecessarily complicated, couldn't you just plug the ethernet from the ISP directly into the Wireless Router?

Also, it may be worth disabling any/all Firewall and network security products you have whilst trying to configure this in order to diagnose fully.

share|improve this answer
    
As I mentioned above I cannot use the ISP cable with the router. –  Darius Sep 24 '09 at 9:50
    
And I also disabled the firewall on the host machine during the initial setup - so it's not the matter. –  Darius Sep 24 '09 at 9:51
add comment

Having thought about it a bit, if you need to do it the way you're trying I think what would be easiest to do is either

a) buy a wifi card for the PC that's plugged into the ISP router and set it to run as an access point for an ad-hoc network

b) buy a second wired nic for the PC that's connected to the ISP then plug the wireless router into that and set up bridging as suggested here

http://www.homenethelp.com/web/howto/windows-xp-bridge-setup.asp

share|improve this answer
    
My current setup is something like the b) point. I have two network adapters in the host machine, one connected to the ISP, one to the wi-fi router (that should work as a switch actually, as hyperslug suggested in one of the posts). I used the Windows' network wizard to share the connection from 1st adapter to other machines using the 2nd adapter, but I'm not sure if the final result is the same as the bridge link you've provided. Will check it as soon as I have access to that network. Thanks! –  Darius Sep 24 '09 at 11:04
    
I think you'll still need the second router as a router in this situation to allow it to do address translation from the PC's connected to it. Also it means you would be able to run DHCP on the outside router instead of having to manually allocate addresses. Make sure you set it to use a different ip range to the one provided by the ISP so probably 192.168.3.0/24 or something similar. –  Col Sep 24 '09 at 11:54
add comment

Most fool proof way:

  • Disable DHCP on the router.
  • Assign each of the machines and the router a static IP.
  • Set the gateway address on all of the devices to the XP machine with the Internet connection.
  • Enable ICS on the XP machine.

Also, you more than likely won't be able to ping the machine due to ICMP being blocked by windows firewall.

share|improve this answer
    
DHCP is disabled on the router, and the firewall is off on the host machine. Still haven't tried the ICS thing, will check that later. –  Darius Sep 24 '09 at 12:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.