Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My provider gave me a new router (which sucks compared to the one I had; 2wire), it's Technicolor TG582n software version 10.2.0.B.

I looked around for remote management in the router administration but there is not such a thing. There is remote assistance but it says it is disabled.

I think it's pretty bad that ANYONE can see the router login page (just type my IP and there it is) and I'm sure it would be easy to brute force the login page.

I have also tried from another network, and I still get the login page.

How can I disable the public login page of my router?

share|improve this question
    
Can you not ask your provider to swap out the device for something more useful? –  user3463 Aug 13 '12 at 20:00
    
on the phone with them. I hope I get a solution. –  user658091 Aug 13 '12 at 20:09

1 Answer 1

You can restrict web login permissions to specific subnets

service system ipadd name=HTTP ip=<subnet>/<mask>

for example

service system ipadd name=HTTP ip=192.168.1.0/24

you can confirm this with

service system list name=HTTP expand=enabled

HTTPS can also be managed replacing the keyword HTTP with HTTPs in the above examples, for Telnet replace it with TELNET...

You can also port forward ports 23 and 80...

share|improve this answer
    
Andrews and Arnold have a reasonably comprehensive page wiki.aa.org.uk/index.php/TG582N –  shouldbeq931 Jan 15 '13 at 21:57
    
is that a firewall? I'm using windows and for my solution I bought a cisco modem. Technicolor is downright horrible. –  user658091 Jan 18 '13 at 13:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.