Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having problems to make lUbuntu v12.04 (the same problems is also with Ubuntu) run smoothly on my Asus EEE box B204 (with Mobility Radeon HD 3400). Graphics performance is very bad. I tried to install Ati drivers from "Additional Drivers" and from AMD.com, but nothing helps - it still slow and don't support video hardware acceleration (with Windows 7 it was running even with Aero and played films 1080p without any problems).

Maybe somebody can give me advice how i can solve this problem ? Thanks :)

Thats how look windows if I moving them fast: http://i.stack.imgur.com/vjz5U.png

GLXINFO:

name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method, 
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
client glx vendor string: ATI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_swap_control, GLX_EXT_visual_info, GLX_EXT_visual_rating, 
    GLX_MESA_allocate_memory, GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control, 
    GLX_MESA_swap_frame_usage, GLX_NV_swap_group, GLX_OML_swap_method, 
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
    GLX_SGIX_swap_barrier, GLX_SGIX_swap_group, GLX_SGIX_visual_select_group, 
    GLX_EXT_texture_from_pixmap, GLX_EXT_framebuffer_sRGB, 
    GLX_ARB_fbconfig_float, GLX_AMD_gpu_association
GLX version: 1.4
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Mobility Radeon HD 3400 Series
OpenGL version string: 3.3.11653 Compatibility Profile Context
OpenGL shading language version string: 3.30 
.......
share|improve this question
    
Weird, that output looks like it loaded fine. Any power management / temperature issues? Can you upload other relevant logs like cat /var/log/Xorg.0.log and dmesg to see if they tell something more like a warning / error? Also, what version of the ATI drivers and did you try an older version? –  Tom Wijsman Aug 13 '12 at 21:21
    
Xorg.0.log, dmesg, glxinfo log files you can find: dropbox.com/sh/681rqq9ia4nd8jf/9ULVAplJIs And now I'm have "AMD Catalyst™ 12.6 Proprietary Linux x86 Display Driver" from AMD.com –  Vladas Gin. Aug 13 '12 at 21:37
    
Ah, that helps. I notice you are using an external screen (hence the HDMI status messages in dmesg.txt) while you are using a laptop (Mobility card). In the past I have noticed some tearing up when both my laptop screen and an external screen where on when I was trying to play video on that external screen; so, have you tried to turn off the laptop screen while you use the other screen (or the other way around) to see if that is the issue? Using one screen only would induce less work on the card. The rest of the log and logs look good... –  Tom Wijsman Aug 13 '12 at 21:42
    
Its not laptop :) Its table-pc (mini-pc), and it has only one HDMI video output - and I'm using it. ca.asus.com/en/Eee/EeeBox_PC/EeeBox_PC_B206/#specifications - I have problems with that one :) –  Vladas Gin. Aug 13 '12 at 21:56
    
This is why I buy NVIDIA. –  ta.speot.is Mar 30 '13 at 2:11

1 Answer 1

I think that this should be solved if you create a custom xorg.conf file. Try this (assuming you have installed the ATI drivers already):

sudo amdconfig --initial

Then restart the X server (Ctrl+Alt+Backspace).

share|improve this answer
    
Hi, I did that, but there isn't any changes :( Terminal log: bedroomtv@Bedroom-TV:~$ sudo amdconfig --initial [sudo] password for bedroomtv: Found fglrx primary device section Using /etc/X11/xorg.conf Saving back-up to /etc/X11/xorg.conf.fglrx-2 –  Vladas Gin. Aug 14 '12 at 7:14
    
Try editing /etc/X11/xorg.conf and changing the driver to vesa. I am getting my ideas from here and here. –  terdon Aug 14 '12 at 12:44
    
As you recomended I changed xorg.conf drivers to vesa. Now xorg.conf looks like: Section "Device" Identifier "aticonfig-Device[0]-0" Driver "vesa" Driver "fglrx" Option "Monitor-DFP1" "0-DFP1" BusID "PCI:3:0:0" EndSection. But still everything is the same :( –  Vladas Gin. Aug 14 '12 at 14:01
    
You should only have one Driver line. Try with vesa only. Remember to restart the X server for the changes to take effect. –  terdon Aug 14 '12 at 14:07
    
I'm restarting all computer, its not enough ? :) How I can restart X server ? –  Vladas Gin. Aug 14 '12 at 14:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.