Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How would I go about creating a filename with invalid characters such as :?>?

Yes I know it is not allowed, but I want to do it anyways. Any workarounds?

share|improve this question

marked as duplicate by Xavierjazz, 8088, iglvzx, Randolph West, Renan Aug 14 '12 at 4:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
A colon is only allowed in Windows 7 GI edition. –  iglvzx Aug 14 '12 at 2:44
    
Note that if you succeed, you won't be able to access the file from any normal Windows application. –  Harry Johnston Aug 14 '12 at 3:34

1 Answer 1

No you cannot.

This isn't a case of escaping the character to get around a GUI or command line limitation, this is a restriction in the kernel. The colon is used for identifying the file stream you are accessing.

Your options are to strip the colons on the source, or replace them with a unicode character that looks like a colon but isn't.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.