Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed a dual boot of Linux Mint and Windows 7.

One of the first things I did was install nVidia drivers via "additional drivers". I then proceeded to configure settings, and saved to the X config - this solved the issue of my multiple monitors not being detected.

However, this also introduced an issue of opening multiple desktop panels (X servers?) with each reboot - in fact, it seems another one is added with each additional reboot:

Screenshot

I was wondering if anybody has had this experience before, or has any suggestions of how to correct this.

share|improve this question
    
Could you post some more information please? Try these commands: ps aux | grep X and ps aux grep panel. Also maybe your xorg.conf file. Which desktop manager are you using? Cinnamon, Gnome3, Mate? –  terdon Aug 14 '12 at 17:12
    
I'm on cinnamon. It seems that after changes are made in nvidia-settings, the save to xorg.conf is what causes this. Upon reboot, it seems to reboot into gnome as shown above. –  nicefinly Aug 19 '12 at 18:20
    
Try asking this over at mint's cinnamon forum, the cinnamon devs hang out there and should be able to help. –  terdon Aug 19 '12 at 19:42

1 Answer 1

Right, I'm going to have a go because I'm intrigued. First of all, are you sure you are using cinnamon? That looks more like MATE.

In any case, I have no idea what is going on but I might be able to point you in the right direction. First of all, you are not running muliple X servers. What you have is a Desktop Environment (Window Manager) problem. Here are a few things you can try:

  1. Follow this guide to install the latest cinnamon version. It has quite a few improvements. You might also post a comment there since Clem, the linux mint and cinnamon lead developer, seems to often respond to comments there.

  2. The command ps list currently running programs. Look at the output of ps aux | grep panel. In cinnamon you should get nothing, in MATE you should get something like:

    $ ps aux | grep panel
    terdon 3623 12.3  3.2 1008896 266816 ?      Sl   03:31   1:19 /usr/bin/mate-s
    

    If you get many such lines, at least we know that it is this program that is launched multiple times.

  3. Have a look at what programs are set to launch automatically. Try looking for "Startup Applications" in the menu, or run gnome-session-properites from a terminal. Also look at the contents of your ~/.config/autostart/ directory.

  4. Rename your config directory and log in again:

    $ mv ~/.config ~/.config.old 
    

    This will remove most of your personal settings, effectively resetting your session preferences. The next time you log in, a default ~/.config directory will be created for you. If the problem goes away, you know it was with one of the settings there. You can now copy the individual subdirectories from ~/.config.old to the new ~/.config. If you log out and back in every few copies, you should be able to identify the culprit.

  5. Make a new user and log with that username. If the problem is gone, then most probably some other settings file (those that begin with a dot '.') in your home directory was at fault.

  6. If that is Cinnamon, check the error tab in the cinnamon looking glass (accessible through the troubleshooting sub-menu in the panel properties menu).

  7. You might also find useful information in ~/.xsession-errors and /var/log/Xorg.0.log.

  8. Come to the linux mint forums. There are subforums for each of the DEs shipped with Mint. Cinnamon is here and MATE here. That's where the people most likely to be able to help you hang out. If you do, please send me a private message (I use the same username and avatar on that site) so I can find your question easily.

OK, that should keep you busy for a while :). I expect option 4 will fix your problem but I'd rather find a more elegant solution than that kind of brute approach.

share|improve this answer
    
Checking "enable xinemera" within nvidia-settings corrected some issues. However, out of frustration, I then installed Ubuntu instead and it works like a charm. I believe this probably due an older graphics card - Quadro FX 1400 –  nicefinly Aug 21 '12 at 0:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.