Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My keyboard has screwed up big time. I was playing Team Fortress 2 and after I closed it out, my keyboard has adopted a weird behavior. Perhaps it is TF2's fault or perhaps I somehow accidentally entered some weird shortcut while playing. Previously, Mountain Lion never suggested alternate letters for the keys that I press (i.e. û, ü, ù, ú, and ū for pressing the u key). Sometimes arrow keys, tabs, and returns seem to be sent when I am not doing so as well as the cursor jumping around. I also can no longer hold a key to repeat it. I really do not want to reinstall Mountain Lion. Does anybody have any ideas as to what will fix this? I have looked in the System Preferences seemingly everywhere to no avail.

share|improve this question
    
Lion and Mountain Lion have a feature that turns off key-repeat, replacing it with similar behaviour to what you describe. I suspect you've run afoul of this setting, which can be disabled. –  user3463 Aug 14 '12 at 7:32
1  
I think defaults write -g ApplePressAndHoldEnabled -bool false is what you are talking about. It does enable key repeat but (1) it worked before fiddling with this and (2) it still don't solve all the other problems. –  Tyler Crompton Aug 14 '12 at 7:34
    
That's why I commented and didn't answer outright. Good luck tracking this down. What happens with a different keyboard? Also, do you think you enabled a foreign keyboard map by accident? –  user3463 Aug 14 '12 at 7:37
    
I don't have another one at hand at the moment. :( EDIT: Sigh. I have to type very slowly. My computer just crashed from replying to you. –  Tyler Crompton Aug 14 '12 at 7:39

1 Answer 1

up vote 0 down vote accepted

Interestingly enough, it has to do with MagicPrefs. I changed some settings while playing TF2. I turned off "Tap to click" option in the "Point & Click" section of the Trackpad settings in the System Preferences (to enabled Taps options in MagicPrefs) and enabled and set both "One Finger Tap" settings in the "MacBook Trackpad" settings in MagicPrefs to "Left Click (Down+Up)". I noticed that it's only the first of the two that causes the problem. It seems to be sending the corresponding action at spontaneous times (when typing). For example, when I changed it to "Right Click (Down+Up)", a context menu frequently showed up. Changing the settings back to normal fixed this. This must be a bug with MagicPrefs and I may get around to submitting a bug report.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.