Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Windows 7 64bit Host system, and I am using VirtualBox 4.1.18 (r78361).

I have an Arch Linux Guest OS.

I have installed VirtualBox Extension Pack (to enable USB2 support) and added my USB device filter to VM.
I have also installed the Guest Additions provided by Arch: virtualbox-archlinux-additions (but I have no idea whether it's actually needed for my environment).

I can see my USB device from VirtualBox Devices menu.

Whenever I am trying to access it, I end up with:

Failed to attach the USB device Kingston DT 100 G2 [0100] to the virtual machine Archlinux.

USB device 'Kingston DT 100 G2' with UUID {a836ec33-0f41-4ca7-a31d-09cceaf5d173} is busy with a previous request. Please try again later.

Result Code:    E_INVALIDARG (0x80070057)
Component:      HostUSBDevice
Interface:      IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee:         IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

From what I have googled, most guides shows how to solve this the other way around - Linux Host to Windows Guest.

How do I resolve this?


I have tried to Eject (virtually, not physically) the device from my Windows Host system and then try to access the Device from Guest. Same error.

share|improve this question
up vote 3 down vote accepted

After an hour of googling and experimenting, I have found the answer.

It looks like VBox has some problems with USB3 hubs, and so, plugging my USB key into an USB2 slot did everything.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .