Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 2.5 SATA drive from an old laptop that ran Windows Vista. In addition to having the main partition with the OS, it has a "Rescue" partition on it.

I put the old drive into an external enclosure and plugged it into a USB 3.0 port on my Windows 7 machine. It first popped up the autoplay dialog for both drives and I dismissed the dialogs.

The main partition of the Vista drive was assigned the E:\ drive letter and the Vista rescue partition was assigned as F:\. I was able access the root directory of the drive and all seemed well.

I was working to take ownership of the \Users directory of the old drive, when I heard the error sound, the drive would click, and the autoplay dialog would pop up repeatedly, along with my antivirus offering to scan the portable drive. I cleared the dialogs, turned off autoplay for everything, and set the AV to not scan the portable drive.

Once I did this, the drive began doing the error sound (presumably when unmounting the drive), click, and then it was "rediscovered" by Windows, over and over again. It then finally offered me the opportunity to format both, which was strange, because it had let me look through the main partition before. It continued to cycle and trying to stop the USB connection did nothing, so I had to unplug it, much to my chagrin.

Will formatting the rescue partition on the Vista drive allow Windows 7 to forget about it mount the main Vista partition properly? If not, how do I get Windows to stop trying to mount the drive over and over again?

share|improve this question
    
I know not a direct answer, but if you can, I'd write a .bat file (xcopy) to just copy the data you want to your main PC - that way you don't have to worry about this issue at all (and you're not playing with the source data either). This will avoid the clicking on the drive and the pop up box. –  Dave Aug 14 '12 at 10:32
    
I don't suppose turning off AVP / Autoplay / or using USB 2.0 makes a difference? (I'm still looking into this with you). –  Dave Aug 14 '12 at 11:16
    
I turned off Autoplay for sure already, I stopped the autoscanning of pluggable drives, but I didn't try USB 2.0. I think since it's a SATA drive it might require the 3.0, but I will give it a go. –  jonsca Aug 14 '12 at 11:18
    
I don't think so - my board had SATA ports etc without USB3.0 –  Dave Aug 14 '12 at 11:21
    
@DaveRook Seems like it's more stable when I plug it into a standard USB 2.0 port. I don't want to speak too soon, though. –  jonsca Aug 14 '12 at 11:25

1 Answer 1

up vote 1 down vote accepted

Please try using a USB 2.0 port (as per the comments in the OP) (or change the power options).

USB3.0 ports are powered. Windows may try to turn off/on the ports to save power (based upon your power settings in power options on control panel). This is on by default in W7 so the device is constantly being turned off and on (with the power saving) and this is probably why Windows kept re-detecting it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.