Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some programs, such as less, have the annoying idea that I should not be allowed to keep loking at the content of a file while I'm typing the next command. They save the contents of the terminal when they start and then blank out all their own output when they exit.

In an xterm, this can be suppressed by setting a *titeInhibit X resource, or at runtime using ctrl-Mouse3. However, cygwin's rxvt-native does not react to ctrl-Mouse3, nor (naturally) does it read X resources.

Is there a way to get rxvt-native to refuse to do the ti-te/smcup-rmcup/alternate screen madness?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

If you don't want LESS to clear the screen when it finishes, just use less -X . You can make this happen by default by setting the LESS environment variable. export LESS=-X .

share|improve this answer
    
Yes, but I'd like a solution that I won't have to repeat each time I ssh into a different server (with a shared administrative account where I'm not supposed to start customizing the profile). –  Henning Makholm Aug 14 '12 at 18:32
    
According to man ssh you can put LESS=-X in the file ~/.ssh/environment and ssh will set that environment variable for you (if you have export permissions). –  dadinck Aug 14 '12 at 20:36
    
That's an interesting idea. –  Henning Makholm Aug 14 '12 at 20:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.