Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

all of a sudden, i can only run chrome as admin. it says the path to chrome.exe doesn't exist, but the file is there after i check.

update menu said i have windows updates installed last night, but when i look through all the updates i can't find anything that were installed last night.

when i right click on chrome.exe and Pin to Start, it doesn't pin it. But pin/unpin to Taskbar works.

even more strange, if i right click on chrome.exe and drag to desktop to create a shortcut, then double click on the shortcut, it works the first time. when double click again, it doesn't work anymore.

tried to re-install chrome but that didn't help either.

oh, double click on chrome.exe works every time but i like shortcut better.

all of above were done while logged in as administrator.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I ran into the same problem tonight. I was able to narrow the issue down to a the latest Chrome update (21.0.1180.79). This is not an issue with the previous version (21.0.1180.77). Specific versions of Chrome are available from filehippo.com

First check this UAC setting:

  1. Run secpol.msc
  2. Navigate to Local Policies->Security Options
  3. Find the policy named "User Account Control: Only elevate UIAccess applications that are installed in secure locations" and set this to "Disabled"

This may alleviate the problem.

Steps to replicate:

  1. Uninstall Google Chrome
  2. Run the 21.0.1180.75 installer
  3. Run the 21.0.1180.77 installer
  4. Run the 21.0.1180.79 installer

The shortcut should now break.

Steps to fix:

  1. Uninstall Chrome with 21.0.1180.79_chrome_installer.exe --uninstall
  2. Reinstall Chrome with 21.0.1180.79_chrome_installer.exe

Alternatively, install the Chrome Browser for Business, which installs itself in Program Files, which is considered a "secure location".

share|improve this answer
    
I like your "User Account Control: Only elevate UIAccess applications that are installed in secure locations - and set it to Disabled" answer more. –  Ray Cheng Aug 17 '12 at 5:45
    
Wasn't sure that was the real issue. I couldn't replicate it. I'll include some information about that. –  Brian Alexander Aug 17 '12 at 5:55

This problem appeared for me after a windows update was installed over night. I have searched and searched and I finally have it working, at least for now. The shortcuts stop working again for other users after a week and the workaround has to be done again. I posted the instructions here but another thing is that Chrome doesn't need to be ran as admin so I made sure to go to its folder (in Program Files x86) and deselect "run as admin" in the properties of chrome.exe

Here is the link:

https://productforums.google.com/d/msg/chrome/agGUrplBu-Y/Gr5Yp2K4gnUJ

Hope this proves helpful! :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.