Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been playing Call of Duty MW3 on the PC. I'm connected wirelessly and when I do this my NAT type is open.

When I disable my wireless and connect using an Ethernet cable to same router, the NAT type is strict.

I have uPnP enabled on the router.

Is there any reason why wireless would be open and wired strict? It's the same router so I imagine it should be the same NAT type no matter how you connect to it.

share|improve this question

migrated from gaming.stackexchange.com Aug 15 '12 at 9:27

This question came from our site for passionate videogamers on all platforms.

    
Your PC will get different IP addresses for Ethernet VS WIFI - check on your router, chances are it's treating the two IP addresses differently. –  Keith Jul 12 '12 at 11:23
    
If you could list your router make and model? –  CyberSkull Aug 14 '12 at 3:33
    
@CyberSkull "Cisco EPC3925" –  PriestVallon Aug 15 '12 at 0:35

2 Answers 2

up vote 4 down vote accepted

While MW3's UPnP compatibility with various routers is indeed spotty at best, the question does not contain enough details about the router settings to provide an authoritative answer.

Based on my best guess from what little information provided, as it seems unlikely for the UPnP to treat the two connections differently in and of itself, it would seem that you have different settings for one of your connections than the other.

This could be the case if you setup a static IP and/or port forwarding for your wireless adapter, but did not do so for your wired adapter. Your wireless and wired connections will have different physical addresses on the adapters and as such will be treated differently by your router. You will need to have the "same" settings for both in the router in order for them to be treated the same - obviously they could/should/would have different static IPs, but both simply having the static IPs and appropriate port forwarding to their respective IPs should suffice.

If you feel certain that UPnP is responsible or related to your issues, there are some UPnP testing tools that you can try at your own discretion to ensure that your UPnP settings are correct. Further information about your setup would be helpful in diagnosing your issue further if needed.

share|improve this answer

Maybe the port was still open for your wireless connection and that is why it couldn't be assigned to your wired connection straight away. I would recommend to forward ports manually, so you have a full control over the situation and you don't need to relay on UPNP.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.