Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Kubuntu 12.04 on a partition of my hard drive and the CPU fan seems to be constantly running. I thought it might be because it was running hot but the temp is floating around 110 degrees F with a load of around 2-12%. I also though the CPU might not be scaling and running at full speed all the time, but that is not the case either. I have the cpufrequtils installed and set to ondemand.

As a test I logged into windows to see the differences, in W7 the temp and load is about the same, but the fan does not run constantly.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

you could try:

  1. (source) Edit /boot/grub/grub.cfg, look for the line that loads your linux system. It should look something like this:

    linux /boot/vmlinuz-3.0.0-1-amd64 root=UUID=addaasa-abcd-1234-a51g-5g4uudh4vak ro quiet splash

    Add the option acpi_os="Linux" like so:

    linux /boot/vmlinuz-3.0.0-1-amd64 root=UUID=badedbe2-adbc-4638-a41b-4a03fe7432cb ro quiet splash acpi_osi="Linux"

    Then run sudo update-grub and reboot.

  2. For tips on controlling a lenovo's fan, have a look at this page. The thinkwiki webpage in general is always a great source of info for linux on lenovo machines.

  3. If you are on a Dell machine (I know you are not, but someone else may read this), use the i8k module: sudo apt-get install i8kutils sudo modprobe i8k sudo i8kfan 0 1

  4. If you are dual booting with windows, check the fan settings there. I had a similar problem and the power settings in windows were making changes in the BIOS which then would affect my linux system as well.

share|improve this answer
    
works, thanks for the info –  Salmonerd Aug 16 '12 at 12:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.