Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been having trouble with the MDS process running wild on my MacBook Pro 13". I've read on other support forums indicating that improperly formatted external drives can be an issue, but I have no drives connected. How can this problem be debugged and fixed?

If it helps, I do have a massive Mail archive. I have not turned off the indexing of this archive, because I haven't been able to find a correlation between the two, but I'm considering it.

(This might be normal right after doing an upgrade from 10.5 to 10.6, in which case the Spotlight search index needs to be rebuilt by mds. But in this case it's been a few weeks.)

share|improve this question
I did a 'sudo killall -9 mdworker' on my wife's macbook and that seems to have solved her disappearing memory problem. – copper.hat Mar 29 '14 at 6:10
For your information, this typical nightmare of Spotlight still happens on actual Yosemite versions. I can't tell for El Capitan yet. – daniel Azuelos Apr 18 at 9:11
up vote 111 down vote accepted

To see what mds and more importantly its child mdworker is actually doing - use fs_usage to log what files it is opening:

sudo fs_usage -w -f filesys mdworker

Though there is a lot of unintelligable stuff in there, it does tell you when it opens a file to begin reading from it. Copying a PDF into my filesystem shows mdworker opening the file then immediately after lots of activity...

p.s. if you want a little less detail, this will just list the open file points:

sudo fs_usage -w -f filesys mdworker | egrep "open"
share|improve this answer
Thanks a lot. I'll look into that. – kubi Sep 24 '09 at 20:18
I wasn't able to solve my problem (haven't seen the MDS issue lately), but I did learn some good debugging commands for situations like this, which is what I asked for. – kubi Sep 28 '09 at 18:20
The Tentacle's answer worked for me. Specifically: My spotlight processes were hanging at 100% CPU and never completed indexing. With fs_usage I was able to see exactly which files hung up mdworker. I deleted the offending folders (they likely had a symlink loop), restarted the Spotlight processes, and everything worked. – Nathan Bowers Feb 12 '11 at 23:44
IMPORTANT: once you figure out which folders or files are causing Spotlight processes to hang, exclude them from Spotlight indexing via the Spotlight "Privacy" settings tab. Sometimes the problem files are auto generated by OSX. – Nathan Bowers Feb 14 '11 at 21:40
If it really is the mds process that runs wild, just replace the mdworker in the command with mds. (This helped me to diagnose the issue when Spotlight suddenly decided to index my Bootcamp partition.) Thanks! – koiyu Mar 2 '11 at 18:38

In the rare case that you would like to disable spotlight, use the following command:

sudo mdutil -a -i off

To re-enable:

sudo mdutil -a -i on
share|improve this answer

Just wanted to note that Spotlight/MDS may not be the issue at all. Errors with Time Machine (particularly where Time Machine takes a long time to "index") can create a situation where Spotlight tries to continually index the same files.

share|improve this answer

You must log in to answer this question.

protected by Troggy Feb 13 '11 at 1:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .