Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to share files between a PC with Windows XP and a laptop with Windows 7. I've been trying to do this for years, which may have resulted in a bit of a mess, but I wouldn't know because I understand very little of what's going on.

There are two computers: Michał (with XP) and Matka (with 7). What I see on Michał is this. In Microsoft Windows Network there are three icons: Home, Mshome and Workgroup. Home has an icon of the router in it. Mshome has an icon of Michał in it, and there various shared folders. Workgroup has an icon of Matka in it, which, when I click it, shows me this:

enter image description here

The only user anybody is using on Matka is called Zojka1, and there is no password. But it won't accept an empty password.

What I see on Matka is this. I go to Network, and there are three computers listed there: Matka, Michał and Netiaspotdrive. Netia Spot is the name of my router. I don't know why this is listed as a computer. Michał has all the shared folders in it -- it's fine. Matka has one icon in it, called Users. In preferences, it is set as shared with "all". But I don't think "all" includes other computers, just every user on Matka. Here are the preferences. I'm posting screenshots because I don't know how to translate the various things I'm clicking and seeing to English.

enter image description here

("Udostępniony" means shared.)

When I click Udostępnianie zaawansowane, I see this:

enter image description here

I click Uprawnienia to see:

enter image description here

("Wszyscy" means all.)

Dodaj gives:

enter image description here

And then under Lokalizacje, there is only one item: Matka. Michał isn't there.

Could you please help me make Matka's files available on Michał?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

You must use a password in order to use a specific user to access a share.

On Windows 7 you have to go to "Network and Sharing Center" in your "Control Panel". Once you've opened it, you click on "Change advanced sharing settings". Expand "Home or Work". You have to "Turn on network discovery", "Turn on file and printer sharing", you can decide if you want to share your public folder, in some cases it's better to "Enable file sharing for devices that use 40- or 56-bit encryption" but I would try that only if it doesn't work otherwise, and finally "Use user accounts and passwords to connect to other computers".

You can take this HowTo as rough reference: http://www.howtogeek.com/howto/windows-7/share-files-and-printers-between-windows-7-and-xp/

Note: my last point, regarding the encryption isn't in this howto but you'll find it at the bottom of the list. Follow the linked howto until the public folder point where the howto writer suggests to turn off password protection for public folders. I don't suggest doing this!

share|improve this answer
    
Thanks a lot! I did it and I could see two Matka's users from Michał: Default and Public in the folder \\Matka\Users\. Zojka1 wasn't there. I changed the sharing settings of the folder again, and it appeared not in Users, but next to Users, directly in Matka. But clicking it gives an access denied message. What should I do to get access to that profile folder? –  ymar Aug 15 '12 at 14:04
    
there are two places where to look if you get an access denied error while accessing a share: The sharing permissions and the security. You can access both by rightclicking a shared file/folder, clicking properties and chosing either "Security" or "Sharing". To setup permissions for sharing, you have to click "Advanced Sharing" and then on "Permissions" at the bottom. This should be similar on Windows 7 and Windows XP. –  wullxz Aug 15 '12 at 14:17
    
I've been to both places, but I can't find the other computer there to give it any permissions. Shall I post more screenshots? –  ymar Aug 15 '12 at 14:34
    
you have to do it locally. –  wullxz Aug 15 '12 at 14:38
    
Thank you for your help. I've managed to make it work now. –  ymar Aug 15 '12 at 14:42

As soon as you set up a password, you'll get access. I made the same experience trying to connect from windows XP to windows 7 computers.

Windows has some rules to provide a 'basic security'. So it's for your safety to install passwords to your accounts.

share|improve this answer

Turn on network sharing discovery mate, should resolve the issue

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.