Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Windows 7 opening Run dialog (Win+R) and confirming with Ctrl + Shift + Enter ran specified command elevated.

In Windows 8 this trick doesn't work anymore and I miss it a lot!

Is there a way to get this feature back?

share|improve this question
    
never had to do that when using win+r in a admin user account in W7, it ran elevated by default. – Moab Aug 15 '12 at 22:12
2  
@Moab Not if you have UAC enabled. – Darth Android Aug 15 '12 at 22:13
2  
For me, this only works in the Windows 7 Start menu, but not in the Run dialog. And that functionality is still there in Windows 8. – Oliver Salzburg Aug 15 '12 at 22:23
    
Not on any of my systems with UAC enabled. – Moab Aug 15 '12 at 22:24
1  
@OliverSalzburg Is the shortcut Win+R (show Run prompt) dead in Windows 8? This is one of the most useful Windows shortcuts in my opinion. Along with Win+E (show Explorer), and Win+D (show Desktop). – sammyg Aug 3 '13 at 22:17
up vote 17 down vote accepted

Do not press Win + R.

Instead, just press Win and type the command directly into the Metro interface. As you type, the search interface will start bringing up possible matches, but just ignore them. When you're done typing, press Ctrl + Shift + Enter, and the command will run elevated, as expected.

This works perfectly for full commands with arguments. It also works for commands without arguments, but with some caveats (matching shortcut, multiple executables, etc.). I have not generally found these to be a major problem.

share|improve this answer
    
Thanks! I just realised that I have been using Win / cmd / Shift+Ctrl+Enter all the time. :) – David Vidmar Aug 16 '12 at 8:30
    
This does not seem to work for me all the time when using parameters. Very often, Windows search will open with the exact search term displayed on the left which I can then click to execute the command, but I wan’t it executed when pressing enter instead. For example cmd /c echo.foo. – poke Jan 9 '14 at 19:28
1  
This behavior seems to have changed in Windows 8.1. If you have parameters, you can press Ctrl-Shift-Enter a second time to execute the command from the search results screen. Or press the down arrow key before hitting Ctrl-Shift-Enter. – taoyue Jan 23 '14 at 0:38
    
Figured it out, and posted an answer below (it restores the functionality via a local policy). – BrainSlugs83 Oct 24 '15 at 19:09

Okay, I figured it out. It seems to be caused by new a feature of UAC called "Admin Approval Mode" or "AAM". You can disable this feature and (at least with UAC turned off as well) Win+R will run applications as elevated by default. -- I have tried this on 3 machines now and it has worked for me every time.

Here's how to go about disabling it:

  1. Open Local Security Policy editor (on the Start screen type "secpol" and right click it, "Run as administrator").

  2. From the menu on the left, expand "Local Policy".

  3. Under the expanded "Local Policy" heading, select "Security Options".

  4. On the panel on the right find "User Account Control: Run all administrators in Admin Approval Mode", open this setting and change the value to Disabled.

SecPol - User Account Control: Run all administrators in Admin Approval Mode

  1. "OK" out of everything, and reboot (at least on my machine it said that a reboot was required, YMMV).

 

If it all worked right, when you hit Win+R at your windows desktop you should see the little shield below the text box that says "This task will be created with administrative privileges."

You can see that this works.

(Note: Depending on your luck, you may have to turn off UAC as well.)

share|improve this answer
    
Verified, this works in Windows 10 too. – BrainSlugs83 Oct 27 '15 at 3:01

^ ^ I just signed up to comment about this, but I don't have 50 reputation to reply to the above. So I will reply in a new answer.

"Okay, I figured it out. It seems to be caused by new a feature of UAC called "Admin Approval Mode" or "AAM". You can disable this feature and (at least with UAC turned off as well) Win+R will run applications as elevated by default. -- I have tried this on 3 machines now and it has worked for me every time."

This indeed seems to be the only way to make the Windows Start Menu 'Run Command' ALWAYS run with administrator privileges. If you have a machine like me that is a Windows 'Home' product, the registry key can be found at

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System clicking on that, on the right side there is 'EnableLUA'. Right click 'Modify' this to value '0' instead of '1' and that does the same thing of disabling UAC. Which apparently, is exactly the same thing as 'built in admin approval', or that the admin approval only works when there is the UAC enabled to 'control' the different user/admin account privileges/access rights.

I've ended up giving up and making an admin enabled shortcut to cmd prompt and placing it above the 'programs' folder on my start menu, as this is pretty close to near my 'run' button (just above shutdown on my modified 'classic Start Menu' modded Windows 10 Home edition). Otherwise with UAC off, I am able to get admin rights on my run command in the start menu BUT CANNOT get rid of the error (doesnt seem to do much, stuff works after clicking 'ok' on it but don't like seeing it) - http://www.bleepingtech.com/windows-8-fix-this-app-cant-open-for-built-in-administrator-account/ This app can’t open for Built-in Administrator account please sign in with a different account and try again .. trying that fix but I don't think there is any way to get admin rights on the run command, without disabling UAC, which in turn gives that error..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.