Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I run command

ffplay -t 3 test.aac

it just plays the whole file, instead of 3 seconds. What command would be used to set duration of playback?

share|improve this question
up vote 1 down vote accepted

It appears that the -t option does not work on all files. I tried this command

ffplay -t 3 test.mkv

and it worked fine. As a workaround this command works for the aac file

ffmpeg -i out.aac -c copy -f adts -t 3 - | ffplay -autoexit -
share|improve this answer

I would suggest adding autoexit to your command:

ffplay -t 3 -autoexit test.aac

If that doesn't work, I would suggest an alternative (mplayer):

mplayer -endpos 3 test.aac
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .