Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When installing some programs or when trying to run .vbs files, Windows informs me it cannot find VBScript.

I have tried everything I can find online, including:

  • Registering the .dll: regsvr32 %systemroot%\system32\vbscript.dll - I get a successful message each time I register.

  • Running sfc /scannow.

  • Ensuring the registry key points the right place.
    C:\Windows\system32\vbscript.dll and not some anti-vir screening file.

  • I can see the .dll file in both system 32 and sysWOW64.

Any advice on how to proceed would be appreciated. Also I cannot find any place where I might re-downloaded the VBScript engine.

More information:

The .vbs file format is associated with the Microsoft Windows Based Script Host. This information is from the File Associations section of the Control Panel.

When I try to run a .vbs file I received an error window stating:

Windows Script Host - Can't find script engine "VBScript" for script "C:****.vbs".

share|improve this question
are the .vbs files correctly associated? What is the exact syntax of the error message you receive? – MaQleod Aug 16 '12 at 17:41
up vote 1 down vote accepted

What happens when you run cscript.exe or wscript.exe? That's how you run (those) scripts on Windows.

It could be getting blocked by group policy, as well - I've heard of that being done in some corporate environments, though it was a temporary thing.

So, look for wscript.exe or cscript.exe, attempt to run them, see whether they're missing or what error message you get when running them, etc.

share|improve this answer
When I run csscript.exe (C:\Windows\System32\cscript.exe) it seems a command line box appears for a fraction of a second and then dissapears, nothing else happens. When I run wscript.exe (C:\Windows\System32\wscript.exe) a window opens titled Windows Script Host Settings. This error is occurring on my personal machine, no group IT settings are on it. – Jonathan Aug 16 '12 at 18:52
Try hitting Win-R (Windows key + r) then cmd.exe and press enter to open a command prompt that doesn't go away. Then try running cscript.exe. – Mark Allen Aug 16 '12 at 18:59
Nothing happened. I then dragged the cscript.exe file unto the cmd box. It ran and I ended up with a bunch of commands under the title Microsoft (R) Windows Script Host Version 5.8. Commands include //B Batch mode //D Enable Active Debugging. Screen cap here: ( – Jonathan Aug 16 '12 at 19:12
Great, that means it's working! Now, from the command prompt run: ASSOC .vbs followed by ftype VBFile. .vbs files work on my computer, and here's that those two commands say when I run them: - if yours looks the same, then .vbs files should run. If yours looks different, then that is the problem. – Mark Allen Aug 16 '12 at 19:57
I get exactly the same when I follow those steps. It seems like everything is squared away but for some reason my machine just refuses to understand when it comes to actually running the files. – Jonathan Aug 16 '12 at 21:52

The error "Can't find script engine VBScript..." can occur if the dynamic link library (DLL) VBScript.dll isn't installed properly -- even if its physically on your system (as opposed to actually being missing).

Try to register it by entering regsvr32 VBScript followed by the Enter key at a Command Prompt or using the Windows Run command (which you can bring up by typing the Win+R key combination at the same time).

share|improve this answer
Done. No change, still getting the same error window. – Jonathan Aug 16 '12 at 19:30

Easy! I had the same problem before... :/

Solution For Windows 7:

1) Open "regedit".

2) Click yes if a dialogue box appears (for making changes to your computer).


4) Open: "CLSID".

5) Open: "{B54F3741-5B07-11cf-A4B0-00AA004A55E8}".

6) Click Once On: "InprocServer32".

7) Click Once On: "Current Version".

8) Double Click On "(Default)"

9) Where it says "Value Data", change that to "C:\Windows\System32\vbscript.dll".

NOTE: If you had McAffee previously installed, it might have been "C:\Program Files\Common Files\McAfee\SystemCore\ScriptSn.20120217033008.dll" as the previous Data Value. Ignore this and follow step 9.

10) Restart or shutdown the system.

11) Done! Simple as that. :D

Hope this helps! :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.