Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried installing dotnet20 and msxml6 with winetricks, but both fail with different errors.

It seems that dotnetfx20 isn't available anymore at the microsoft download center.
Here's my output for the command winetricks dotnet20:

LinuxSchnitzel Downloads # winetricks dotnet20
Executing w_do_call dotnet20
Executing load_dotnet20
Executing w_do_call fontfix
Executing load_fontfix
Setting Windows version to win2k
Executing winetricks_early_wine regedit C:\windows\Temp\_dotnet20\set-winver.reg
Executing mkdir -p /root/.cache/winetricks/dotnet20
Executing unzip -o -q -d /root/.wine/dosdevices/c:/windows/syswow64 l_intl.zip
Executing mkdir -p /root/.cache/winetricks/dotnet20
Downloading http://download.microsoft.com/download/5/6/7/567758a3-759e-473e-bf8f-52154438565a/dotnetfx.exe to /root/.cache/winetricks/dotnet20
--2012-08-16 19:30:03--  http://download.microsoft.com/download/5/6/7/567758a3-759e-473e-bf8f-52154438565a/dotnetfx.exe
Resolving download.microsoft.com (download.microsoft.com)... 80.239.221.105, 80.239.221.91
Connecting to download.microsoft.com (download.microsoft.com)|80.239.221.105|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2012-08-16 19:30:03 ERROR 404: Not Found.

------------------------------------------------------
Downloading http://download.microsoft.com/download/5/6/7/567758a3-759e-473e-bf8f-52154438565a/dotnetfx.exe failed
------------------------------------------------------

So, what do I do now? I tried installing .Net Framework 2.0 SP1 x64 manually, but that fails either with no specific error message.

msxml6 is apparently available but it fails. A message dialog tells me, that msxml6 isn't made for 64-bit. How do I configure wine to get the 64-bit packages?
Output:

LinuxSchnitzel Downloads # winetricks msxml6
Executing w_do_call msxml6
Executing load_msxml6
Executing mkdir -p /root/.cache/winetricks/msxml6
Using native,builtin override for following DLLs: msxml6
Executing winetricks_early_wine regedit C:\windows\Temp\_msxml6\override-dll.reg
Executing wine msiexec /i /root/.cache/winetricks/msxml6/msxml6_x86.msi
fixme:storage:create_storagefile Storage share mode not implemented.
err:msi:ITERATE_Actions Execution halted, action L"LaunchConditions" returned 1603
------------------------------------------------------
Note: command 'wine msiexec /i /root/.cache/winetricks/msxml6/msxml6_x86.msi' returned status 67.  Aborting.
------------------------------------------------------

I'd like to install MS Office 2010 x86. Do I need to configure wine for 64-bit?

Update:
I managed to install msxml6. To be able to do that, I had to rename ~/.wine to something else and recreate the wine config with $ WINEARCH=win32 winecfg.
Installing msxml6 worked without problems then.

Update2:
Now that I've set wine to run in 32-bit mode, I was able to download dotnetfx.exe from filehippo and ran it with $ wine dotnetfx.exe.
Sadly, the installation failed: enter image description here

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I ran into the same problem yesterday. I posted a fix on the ubuntu forums: http://ubuntuforums.org/showthread.php?p=12176837

Maybe that works better than the file from filehippo.

Edit: Make sure that wine is in 32 bit mode as specified on the wine-hq page for .net 2.0

share|improve this answer
    
Note: to run wine in 32-bit mode, one has to delete ~/.wine and run WINEARCH=win32 winecfg. All installed applications will be lost then, so backup your .wine directory. –  wullxz Aug 19 '12 at 21:20
2  
This is not correct. You can specify WINEPREFIX=~/.wine-32 and then run wineboot. Then you will have a 64 and 32 bit version of WINE. Depending on what your environment variables are only one of those is used. –  Azrael3000 Aug 20 '12 at 6:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.