Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a cable modem from my ISP to which I can only connect wirelessly.

Currently I have a desktop PC(windows 7 x64) a dell laptop(windows 7 x64) an iPod(iOS 3.1.3) and a linksys wrt54g router (v8 with dd-wrt)

Laptop and ipod behave as expected. They get an IP that stays mostly the same. for example 192.168.0.4 & 192.168.0.2 My desktop PC does not have a wireless card so I wired it to the linksys router. The router is configured as follows (as outlined in the dd-wrt.com help & tutorial pages):

  • Wireless mode: Client Bridge
  • SSID and wireless security is configured exactly as in the ISPs modem
  • DHCP is disabled
  • fixed ip address 192.168.0.50

At first all seemed OK. But then I started to notice that the desktop PC could not be pinged with the hostname. Only by IP.
I then noticed that the desktop IP address would change even though the computer was not shut down. Not even it's IP released/renewed. Sometimes it changes every few minutes. sometimes after a few hours and other times not at all for the whole day. It keeps adding up. So if the ip was 192.168.0.8 it would then be 192.168.0.9 now it's at .0.100. It is a problem since connectivity is lost while transferring files, streaming, shared folders, etc.

I suspect it is the routers fault but I don't know where to start looking to correct this issue. Any help or pointers are appreciated. Thanks!

share|improve this question

1 Answer 1

Without logs (from the router) to shed light on why it's happening in the first place, I'll describe what should be the simplest fix and also help troubleshoot a possible cause.

You can set a static IP address on your desktop; under the network adapter settings for IPv4, switch from "Automatically Assigned" to an manual, and set your IP to an unused IP (something like 192.168.0.20. Set your subnet to you 255.255.255.0 and gateway to your routers IP address. You should also be able to set your DNS servers to either your routers IP, or a public DNS service (Google provides this @ 8.8.8.8 and 8.8.4.4).

If you continue having issues after you do this, I suspect you have a bad ethernet cable, ethernet card, or port on your router.

share|improve this answer
    
Thanks for your help! I changed to a manual ip and it didn't work at first. I had to replace the ethernet cable and then I had a working network. The pc is still not pingable via hostname. If I switch back to automatically assigned IP the old behaviour returns. Every few minutes a new ip-address. What do you need to know more about the problem? Thank you again! –  leugim Aug 18 '12 at 5:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.