Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Aptana Studio on a Ubuntu system for some Ruby on Rails programming. When I run file-generating commands in the bash terminal provided by Aptana such as rails g migration foo, files are created and linked to in the terminal.

Clicking the links will open an editor, supposedly of the file. However, this editor always shows a blank page, and is not the correct file that was just created.

The terminal-link-to-editor behavior works correctly on the OSX 10.7 machine I've tried it on.

How do I fix this?

I'm using Aptana Studio 3, build 3.2.1.201207261642 on ubuntu 12.04 LTS 64bit. Possibly less relevant, but I'm using ruby 1.9.3-p194 and rails 3.2.8.

share|improve this question
    
Could you run ls -l linkedfile (replacing 'linkedfile' with the actual file name) on the links? –  terdon Aug 17 '12 at 14:55
    
@terdon the file names are shown relative to the root of the project, regardless of current directory within the project. –  bdares Aug 18 '12 at 1:12
    
I was just thinking that that way you could check what the links are pointing to and whether the relevant files exist. –  terdon Aug 18 '12 at 1:14
    
@terdon the files do exist in the indicated directory... I think aptana studio is using a different base path when following the relative link. –  bdares Aug 18 '12 at 1:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.