Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am cleaning up some files in my web server... I came across an old Wordpress site and went to delete it. Everything went but for one theme... when I try to delete the directory I get a warning saying that I need permission from Administrators to change the folder. Mind you, I am logged in at Administrator, the only user in Administrators.

I have tried just about everything I have every heard of and still can't delete the folder. Any advice?

share|improve this question
Since you're talking about Server 2008 I'm guessing you're on IIS? If so did you make sure the application pool was stopped? Also have you tried rmdir or del from the command prompt? – Mr.X Aug 17 '12 at 6:51
Access denied from the command prompt. IIS isn't running. I'm telling you, I have done everything I have ever even HEARD of to do. These files will not go. – aserwin Aug 17 '12 at 6:58
Have you checked the permissions on the folder? Right-click on it, select Properties, then go to the Security tab. If necessary, add full permissions to your user account (or the Administrators group). – Indrek Aug 17 '12 at 7:41
I can't change permissions... Access denied. This is the strangest thing I have ever encountered. – aserwin Aug 17 '12 at 7:41
Who is the owner of the directory? – dsolimano Aug 17 '12 at 12:05
up vote 3 down vote accepted

Right Click the File - Properties - Security - Advanced - Owner - Edit => Choose Administrator or the Administrator Group. See if you can modify the Persmissions now.

If this isn't working, try to find out, what process locks the file. There are many tools that can tell you that. One is "Process Explorer" from Microsoft

If nothing else works, and you really need to delete the file. Boot your machine in save mode and try to delte it there. Also you could try a "File Unlocker" Program - won't link to one tough because that's really not the way these kind of problems should be solved...

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .