Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a broadband router (Linksys E1000) which I've flashed with a DD-WRT firmware. After doing so I realized that this router doesn't have an interface for ADSL port(RJ-11). How can I use the Linksys E1000 for my home network?

I've heard that I can use ADSL modem(not a router) & plug the RJ-11 to it & take from it the Ethernet & plug it back to the E1000(in the WAN port) would that mean that I can get just a modem and not a hybrid?

Note: Also, I have to mention that my ISP is using PPPoA & DD-WRT is not supporting it, but i googled & they said that the ADSL modem cab be the rescue. Can I pick any ADSL modem for this specific scenario or am I looking at a specific model?

Secondly, can I use my old router to do the job instead of buying a new ADSL modem ? & is it a good approach ? or should i buy a new ADSL modem ?

Update

I solved it in another way, i turned my DD-WRT router(E1000) to act as access point, since this is the only way that i can use it with the DD-WRT feature. & i think this is better than have nothing :) I can now have the DD-WRT functions ;)

share|improve this question
    
If by Linksys E1000 you mean this then all you need is an PhonicUK already said is either just ADSL modem or a ADSL modem/router. – Darius Aug 17 '12 at 15:31
    
i don't have a adsl modem only & its not available in my country.. oly the adsl/router is available... so, how can i do it know ?? – Q8Y Aug 18 '12 at 14:43
    
What you could try is to put the WAG200G in bridged mode and then attach just a router to it. That is almost exactly what I have at home but different modem and different router than you. Was WAG200G supplied to you by your ISP? If so you can ask them to put that into a bridge mode. – Darius Aug 18 '12 at 15:25
    
no, the router i'v purchased it. & i did put the router to a bridge mode but with no chance to make it work, i don't know why !! i put it to bridge mode only & i did set the vpi/vci. but i don't know why its not working, its seem strange !!! I even try to test it after that with the windows using PPPoE, but also without any chance !! I don't think its from the router i think its from the setting. do i have to call the ISP to tell them that i want to put the router to bridge mode ?? i don't have , right ?? – Q8Y Aug 18 '12 at 16:08
    
If you found a solution to your problem yourself, please post it as an answer and mark it as the accepted solution. – Oliver Salzburg Aug 19 '12 at 12:48
up vote 4 down vote accepted

You need to buy either:

  • A) standalone ASDL modem to plug into your existing router.
  • B) A combined ASDL modem-router. (Which you can check beforehand if it supports DD-WRT)

Also, lay off the question marks a bit ;)

share|improve this answer
    
unfortunatlly, in my place i don't have a standalone Adsl Modem, so, i have to go with the option to use my (old) router & disable the router feature & use it as only a modem. But iv tried to go for that approach but it didn't work for me till now. !! I'm using the 'WAG200G' linksys to do that job... Do u have a solution for that ?? – Q8Y Aug 18 '12 at 9:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .