Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I added console=ttyS0,57600n8 to my kernel command line. I get the normal boot messages until this

[ 5.123106] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
Begin: Running /scripts/local-bottom ... done.
done.
Begin: Running /scripts/init-bottom ... done.

Then no more output. I am trying to debug a kernel panic using kdump, but can't quite get kdump to work. I want the serial console to get kdump working.

[edit] I worked around the problem using a virtual machine.

share|improve this question
1  
You should try removing the "quiet" and hte other option from the grub config too. I can't remember it's name now, sorry. If you post a picture about the grub config (at boot), I'll help you pinpoint the other option too. –  Shiki Aug 17 '12 at 17:32
    
do you want me to hit e and take a pic of the kernel arguments? –  Brian O'Dell Aug 17 '12 at 18:22
1  
Yes............. –  Shiki Aug 17 '12 at 21:57

1 Answer 1

up vote 1 down vote accepted

You will almost certainly also need to update your inittab, or upstart configuration in addition to the kernel options.

init - /etc/inittab

T0:23:respawn:/sbin/getty -L ttyS0 57600 vt102

Upstart - /etc/init/ttyS0.conf

# ttyS0 - getty
#
# This service maintains a getty on ttyS0 from the point the system is
# started until it is shut down again.

start on stopped rc or RUNLEVEL=[2345]
stop on runlevel [!2345]

respawn
exec /sbin/getty -L ttyS0 57600 vt102
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.