Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just copied whole site with XCloner (extention for joomla) and flushed it into my localhost enveronment.
The main page and all administration interface are working and things seems be same between production and localhost enveronments, but just I click on some menu item I receive error 404...

For example:
http://site.fr/plateaux-repas-paris - give the page
http://localhost.com/site/plateaux-repas-paris - give 404 error
http://localhost.com/site - give main page
http://localhost.com/site/administrator - give administrator login page

I don't know where start to dig...
Some ideas?
I guess it related to Apache configuration, because joomla instalation just mirrored from the site.

Thank you for ahead.

share|improve this question
    
localhost.com was need for escape error. –  Rodnower Aug 17 '12 at 19:52
add comment

1 Answer 1

up vote 2 down vote accepted

The most likely cause is that you have Joomla's SEF/SEO settings turned on and your local copy doesn't include the .htaccess file (they're often missed by the free backup utils).

Just copy your htaccess.txt file to .htaccess and you should be fine.

share|improve this answer
    
Yes, I checked .htaccess file, enabled mod_rewrite in httpd.conf and restarted web service. SEF settings: Friendly URLs - Yes, Use mod_rewrite - Yes, Add suffix - No. I have no errors in error.log of Apache2. Interesting that in one trial it worked and changed url to index.php?compoment=.... and opened the page but other cases it not worked. From my expirience, mod_rewrite on Windows is VERY non deterministic and working only SOME-TIMES. So I suspecting that the problem is in mod_rewrite. It is why it working on server (Linux) and not on Windows. –  Rodnower Aug 18 '12 at 11:01
    
And! I forget put AllowOverride All. Now it completely works!!! –  Rodnower Aug 18 '12 at 11:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.