Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Consider the case where Raspbmc (Raspberry Pi media center) is connected to a home wireless router. There are many computers also connected to the home wireless router and they are on a Windows homegroup network.

How to access and play media files in shared folders on a Windows homegroup computer from the Raspbmc?

share|improve this question
    
I highly doubt Raspbmc supports the Windows 7 Homegroup system. But regular/traditional file shares should be accessible (although I don't use Raspbmc, so I can't speak to it's abilities). What have you tried already? Where are you getting stuck? Firewalls, share permissions? –  Ƭᴇcʜιᴇ007 Aug 18 '12 at 4:43
    
The shared folders are shared with "everybody" for read-write access. So, there should be no permission problem. I can SSH into the Pi from any homegroup computer. What do I need to do on the homegroup computer and the Pi to get access? –  Ashwin Aug 18 '12 at 4:47
    
"Everybody" is only everybody known to the Windows machine. Are you providing credentials when you try to access it? If not, have you allowed Anonymous access? Are you sure the permission are correctly set on both the shares themselves and the files/folders that are begin shared? How are you trying to access it? What's happening when you try to access it? –  Ƭᴇcʜιᴇ007 Aug 18 '12 at 4:52
    
How to give Anonymous access? I get "Error 2: Share not available" in Raspbmc when I access SMB section of Files explorer. –  Ashwin Aug 18 '12 at 4:56

1 Answer 1

Since it doesn't sound like you're providing any credentials from the Pi, perhaps ensure you are allowing Anonymous access to the Windows shares.

Keep in mind "Everyone" is not the same as Anonymous. But you can make Windows behave that way...

To enable anonymous access on a local workstation or server computer

  1. Open Local Security Settings. (Start->secpol.msc).

  2. In the console tree, double-click Local Policies, and then click Security Options.

  3. In the details pane, right-click Network access: Let Everyone permissions apply to anonymous users, and then click Properties.

  4. On the Local Security Settings tab, click Enabled, and then click OK.

Instruction source is Microsoft

Note: I don't think Secpol.msc exists on Home versions of Widows.

share|improve this answer
1  
Thanks. After I do this, what to do on the Raspbmc to find the shared folders? –  Ashwin Aug 18 '12 at 5:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.