Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Just reinstalled a Lenovo laptop with Vista.

Two separate USB sticks, that work fine on another computer, will not show up on this Vista computer. USB ports work fine for other stuff. USB sticks worked before I reinstalled the computer.

After looking around, I tried going into Disk management, to see if they appear there - they don't.

Is there some sort of service, that might be disabled, not allowing removable drives to mount? Or what else can be wrong?

share|improve this question

What version of USB is on the laptop? I've seen behavior like that in machines which only supported USB 1.1, when the device required 2.0. OTOH, I can't remember the last time I saw a USB 1.1-only machine -- maybe 2003? 2004? I doubt you've installed Vista on a laptop of that age.

I don't think it's a service issue; I can't locate any services on my machine (admittedly Win7) which appear to be responsible for drive access.

You may want to plug in the memory stick, wait a few moments and pop over to Device Manager to see if there's anything there indicating an issue.

Does anything come up in the auto-detect / remove hardware notification area when you plug it in? Maybe it's a simple device driver issue? (Although to be fair, I haven't seen any version of Windows choke on memory sticks since they started getting popular.)

share|improve this answer
up vote 0 down vote accepted

After trying all kinds of tricks, also the stuff John Rudy suggested - I eventually gave up and installed windows 7 on the pc. Then everything was fine.

For future reference, the machine was a brand new Lenovo W500 - and it was the preinstalled Vista.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .