Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 disks in MBP: SSD and regular HDD. I keep only data files on HDD and do not need them often. The problem: even if I eject the HDD drive from Finder or Disk Utility, when macbook is awaken from sleep, OS automatically wakes up HDD. Is it possible to prevent it?

Addition: Ideally it would be cool to make OS not to spin up even mounted drive.

share|improve this question
    
Is unplugging the disk an option? –  terdon Aug 18 '12 at 15:11
    
@terdon what do you mean by unplugging? the disk is inside the notebook –  ivanzoid Aug 18 '12 at 16:17
    
Hmm... I guess it is not an option then huh? :) Sorry, since you said "eject" I thought it was an external drive. –  terdon Aug 18 '12 at 16:34
add comment

1 Answer

I think your best bet would be to set the drive to only be mounted manually. I imagine there is a GUI way to do this in OSX but the following, UNIX, approach should also work.

Edit the file /etc/fstab and look for the line mounting the relevant drive. Should be something like:

UUID=a180cec0-xcad-4344-2e19-7b0249ef23b0   /Volumes/foo    hfs rw,auto 0   0

The first field is the disk name or UUID, the second is the mount point, third is the file system and fourth is the options. The last two are for integrity checks and can be ignored for now. Remove auto (if present) from the options field and add "noauto":

 UUID=a180cec0-xcad-4344-2e19-7b0249ef23b0  /Volumes/foo    hfs rw,noauto 0 0
share|improve this answer
    
The disk isn't mounted since he ejected it before sleeping. But it's apparently starting to spin despite that. –  Daniel Beck Aug 18 '12 at 16:45
    
@DanielBeck I know, but I figure that when the computer wakes up, it reads fstab and mounts what needs to be mounted. If the drive is set to not automount I would expect it to remain asleep. –  terdon Aug 18 '12 at 16:49
    
@terdon, wow, it looks that /etc/fstab is no longer used in Mountain Lion. :( It's only /etc/fstab.hd exists with the following contents: pastebin.com/T6cZne4t –  ivanzoid Aug 18 '12 at 17:13
    
@ivanzoid terdon wanted to address you in his above comment. –  Daniel Beck Aug 18 '12 at 17:34
    
According to this question, fstab is still valid just not created by default. Try adding the line I suggested and see how it goes. @DanielBeck, I hope it is :) –  terdon Aug 18 '12 at 18:15
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.