Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Anyone had problems mounting an external hard drive on a mac? It shows up (dimmed) in disk utility and all is fine according to first aid, but it just refuses to mount. It simply says "The disk My Book could not be mounted. Ext. hard drives abled in preferences as should. My Book used to work fine and I've used it for years with my older Mac then suddenly it just dissapeared and won't come back. Same thing when I try it on my newer Mac. It has it's own power supply so that shouldn't be the issue. I restored all files (4 hours) onto another, new external hard drive of another brand (Seagate) and it worked fine but it also seem to copy the invisibility so the problem is the same with the new drive. The old "problem drive (My Book) is formatted Mac OS Extended (Journaled). I tried to format the new drive as FAT before restoring another time, but it changes to Mac OS Extended as copying the files. The older Mac is Macbook from 2007 and the newer one Macbook Pro bought just now. I don't have a PC and would rather avoid it, but will try connecting to one as soon as I get the chance.

I have loads of important files I haven't yet backed up on the drive of course so I would appreciate any help or experiences on this.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.