Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 1.5TB SATA drive with a fresh (working) installation of Windows 7 Ultimate. I decided I'd like to dual boot with Ubuntu. I have a separate 500GB drive that I wanted to use. Previously, my Windows drive was my "primary" (SATA port 0) and also the first boot entry in my BIOS. I wanted to use grub2 as my bootloader. I thought that perhaps installing the bootloader on my Linux drive would be more "aesthetic," so I swapped my SATA cables so that my (soon to be) Ubuntu drive was connected to port 0 and my Windows drive was connected to port 1.

I installed Ubuntu and everything went fine. I forced grub to install to the Ubuntu drive (even though it tried to install to the Windows drive by default). After the installation and updating finished, I was able to reboot the computer and boot into Ubuntu or Windows 7 just fine. However, I noticed that booting into Windows 7 was taking exceptionally longer than it had before. Whereas previously the "starting windows" screen would display for approximately 10 seconds, it was now taking 45-60 seconds. Additionally, I noticed that during most of that time, there was no activity noise coming from my hard drive (even though the HDD light was solid). It wasn't until the last 10 seconds or so of that time that I began to hear the normal noise that I was used to with Windows disk activity.

When starting Windows this way, I noticed that the "boot" tab in msconfig is frozen. I can't click any buttons (though they aren't grayed out) and there are no entries in the list.

Despite all of this, I can choose to boot from my secondary drive within my BIOS. When I do so, my Windows 7 installation boots within the 10 seconds that I expect. In this scenario, the "boot" tab in msconfig is populated and responsive.

I have a feeling that there's a relatively minor issue here somewhere, but I'm not quite sure where. Hopefully it's an easy fix. Does anyone have any ideas?

share|improve this question

1 Answer 1

I'm not sure if this constitutes the "answer," but it's certainly a solution.

I fixed my issue by setting the Windows drive back to SATA port 0 and the Ubuntu drive to SATA port 1. I then reinstalled Ubuntu (may not have been necessary) and set grub to install to /dev/sdb (the Ubuntu drive on port 1). Then, in my BIOS, I set the boot device priority so that the Ubuntu drive (port 1) would boot before the Windows drive (port 0). This caused grub to appear when booting the system, and when selecting Windows 7 from the menu, my short boot time returned.

I don't think Windows was tolerant of not being on the primary disk. Perhaps it's because I installed it on the "primary" disk, but information around the Internet suggests that Windows becomes very unhappy if it doesn't reside on the primary disk of the machine. Lesson learned.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.