Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had an HDMI cable plugged in for a while that connected to a TV with no power. The retina display randomly flashed blue after a while and then changed to a different resolution (possibly 1080p). I unplugged the HDMI cable and nothing happened. So I restarted the computer to no avail. I was still having issues. So I fiddle with some settings after plugging in the HDMI cable again. Now, the retina display appears fine when no HDMI cable is plugged in, but when there is one plugged in, the resolution changes.

I have mirroring turned off (which is what I want). The resolution of the retina display when an HDMI cable is plugged in is 3,360px x 2,100px (according to the size of a screenshot) and the external display is 1,600px is 900px. How can I fix the retina display to show with the correct resolution.

share|improve this question
    
Is the lid open or closed when you are using the hdmi? On my win7 hp g6 if the lid is open and connected to a hdmi tv, both screens mirror at the max res of the laptop (1366 x 768). But if the laptop lid is closed, the res on the laptop & hdmi source changes to max automatically (1920x1080). Just a thought... and this is with sleep/hibernate off when lid closes. –  Logman Aug 18 '12 at 17:41
    
Open. What's interesting, though, is that the retina display is only supposed to go up to 2880px x 1800px. –  Tyler Crompton Aug 18 '12 at 17:52

2 Answers 2

I don't have a Retina display, but if I plug a VGA cable (technically Mini DVI to VGA) into my MacBook Pro when there is nothing connected to the other end, I have the same problem.

My solution is to turn my TV on first, then connect the cable to the Mac. This lets my Mac keep its normal resolution, and my desktop is extended onto the TV.

share|improve this answer
    
Thanks. I fixed it. I'd like to do a self answer but I am really not sure what I did that did the trick. :/ Have an upvote for the answer, anyway. :) –  Tyler Crompton Aug 22 '12 at 5:14
    
Thanks. =D I have often noticed that this type of problem has no definite 'fix'... Sometimes it works, and sometimes it doesn't... =O –  daviewales Aug 22 '12 at 10:27

It worked for me holding Cmd and pressing F1.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.