Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Something unusually has happened recently on my machine: every time I start powershell, it starts with Admin privileges by default. It used to be that it would start just as my user unless I right-clicked, "run as Administrator." Now it only starts as Admin. Any ideas? I'm running a solarized colour script at powershell startup, but that's been there much longer than this issue, and is what tipped me off about the problem in the first place, as it shows an admin shell with a light background, as opposed to a non-admin shell with a dark background

share|improve this question
    
You start PS how, exactly? –  kreemoweet Aug 19 '12 at 2:30
    
it is pinned on the taskbar, but the same thing happens if I run it from cmd; the 'run' menu, or from the explorer. –  askvictor Aug 19 '12 at 6:20

2 Answers 2

Sounds like UAC has been disabled. If that is the case, any application you start will run as admin with no prompt. I can only assume your account is in the Admin group, else your PS could not possibly run elevated.

share|improve this answer
    
Does the same thing irrespective of UAC level –  askvictor Aug 19 '12 at 6:21

If you are starting PowerShell from a shortcut or from the Start Menu: I would check the compatibility tab under the properties of the shortcut you are using. Under Privilege Level make sure Run this program as an administrator is not checked.

You might also check to see if something may have gotten added to your default profile script. You will find it here: %USERPROFILE%\Documents\WindowsPowerShell\Microsoft.PowerShell_profile.ps1

You can also get a normal window by just running from the run window or command prompt powershell.exe -noprofile. This should provide you with a non-administrator console.

share|improve this answer
    
The properties do not have run as administrator checked. Also, powershell -noprofile still gives me Admin. –  askvictor Aug 19 '12 at 6:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.