Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to set up ADSL and WiFi in a country home. I have bought a DLink DSL-2640 modem-router for this. The device is connected to the ADSL, everything works fine. The device has a WiFi AP capability - I have set up the WiFi and I am accessing the network from 2 different iPads, 2 PCs and an Android phone. After a few hours of work I begin to notice that one of the iPads is taking to long to load pages - it even can't load the router's web interface. This goes on for 5-10 minutes or so, then it passes away. Same stuff happens to Android, but rarer. PC has this problem occasionally also, but rarest of all.

I am assuming that this is a problem of the device - ADSL and WiFi might be too much for it. I got a dedicated WiFi router (TP-Link WR740N), connected it to the DLink and turned off WiFi on the D-Link.

Same stuff happens. After a while the Internet stops responding - I can't load the router's web interface. Goes on for 2-10 minutes and passes. WiFi is functional, I can disconnect and connect a device, device obtains an address through DHCP.

I updated both devices to the latest official firmware. I tried switching WiFi channels, switched the router to g-only mode. EM interference is very unlikely since it's a country home and there are no wifi networks around.

I am at a loss and don't know how to debug this further. Any advice is welcome.

Thanks

share|improve this question
    
Two things come to mind when I hear "couple of hours." First is thermal, second is memory. If you turn the router off, and immediately back on, and it lasts for a couple of hours again, that would almost eliminate thermal issues as the possible issue. If you have to leave it off for a while for it to work again, it's likely thermal issues. If it's not thermal, it would likely be memory. The problem would be what specifically is causing this problem? What services are running, what does the configuration look like in the router, for routing specifically? –  Everett Aug 19 '12 at 17:50
    
Have you contacted your service provider and asked them if they see any problems? –  Everett Aug 19 '12 at 17:50
    
is everything wireless? does it happen when it is wired? EMI can be caused by alot of things, not just another wifi... –  Logman Aug 19 '12 at 17:54
    
Thanks everyone for the suggestions. I tried with wired connection and saw no hiccups. Then I looked into my wireless environment once again - there were 2 2.4GHz devices nearby - a cordless phone and a wireless video baby monitor. When wireless stall happened again, I tried to turn off the baby monitor and looks like it helped. I am not 100% sure yet, but it seems that this device uses some devious channel selection algorithm that makes it jump through channels from time to time and end up on interfering with the active wifi connections. Thanks everybody. –  Corvin666 Aug 20 '12 at 14:07

2 Answers 2

Sometimes the simplest answer is doing a 30-30-30 reset on the modem. Beyond that, contacting your ISP is sometimes the best shot. They can make sure that your line quality is up to snuff.

share|improve this answer
    
For quick reference, here's info on 30-30-30 resets from dd-wrt and from About.com (I know, I know, but this article seems okay). –  Pops Aug 20 '12 at 21:13

I have been experiencing this many times and with several routers. The only solution is always the router reset. The delay on loading the router’s own administrative page would suggests the problem is the router OS and not the upstream ISP connection. For sure you are using the ISP provided router and they know what’s going on; my advice; replace the router for one of higher quality.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.