Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After installing VirtualBox, I noticed that my computer (Windows 7) was taking an unusually long time to establish a wifi connection on startup. I found this "trick" and I tried it: http://scottiestech.info/2010/12/31/fix-slow-windows-networking-problems-when-virtualbox-is-installed/

Disabling the Host-Only Network adapter did nothing. On further reboot, it was still taking close to a full minute to get onto my wifi network.

To confirm that this was VirtualBox-related, I completely uninstalled VirtualBox from my machine. After uninstalling and rebooting, my wifi connection instantly connected.

Are there any other things I can try, besides Disabling the Host-Only Network Adapter, to fix this problem?

share|improve this question
    
I have even tried installing Virtualbox without including the Host-Only Networking option at all. Still the same problem. –  Josh Aug 21 '12 at 2:48
    
Also, possibly relevant, when I install Virtualbox, my "Virtual Wifi Miniport" adapters disappear. –  Josh Aug 21 '12 at 2:55
    
OK.. if I also don't install the Bridged Networking option, then I can get the machine to boot up and connect to wifi properly.. and all of the VMs' networking functionality works too (behind NAT). I guess I've answered another of my own questions. –  Josh Aug 21 '12 at 3:07

2 Answers 2

I had exactly the same problem. Much simpler fix was, via Network and Sharing Center, to change Wifi Adapter settings. Simply uncheck "Virtual Box bridged newrok adapter" in Networking tab, and your wifi will establish connection within seconds, not minutes. Whenever you need bridged networking via wifi card for your Virtual Box, you can check it back. Meanwhile, bridged networking still works on your wired NIC.

share|improve this answer
    
Worked for me as well. Had the problem trying out Docker on Windows... –  mmey Sep 21 at 0:49

Yup, just for people who find this question in the future: I did end up solving this myself by installing VirtualBox with all of the networking options disabled. Using NAT still seems to be working fine for my purposes. If I ever find the need to use the Bridged or Host-Only networks, I will revisit this question.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.