Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just cloned TextMate 2 from GitHub. Followed the instructions in the readme file and everything went smooth with the installation. However, there is no syntax highlighting.

No problem – just need themes, right? I found a theme I liked, downloaded and installed. Everything seemed to go fine. However, quitting and restarting TextMate 2 doesn't give me my theme in the menu I see.

View > Theme > No Themes Loaded

What?

share|improve this question
add comment

1 Answer

View > Theme is a red-herring. Ignore it.

Go to TextMate > Preferences and choose Bundles. Themes are in bundles in TextMate 2. In the Bundles tab, you can click themes near the top to filter theme-bundles.

Choose the bundle called Themes. When you check the box, it will download and install. Quit, relaunch and you're done.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.